White screen glitch


#1

I trie to play some games but it glitches and turns white


#2

that doesnt happen to me…


#3

Can you try to get a photo of this happening? It may help figure out what’s going On.


#4

Try updating. I think i know what you mean.


#5

yeah. it could be dat too.


#6

@Metros does it look like this?


#7

Does it go, “whomp”

Solutions:
1. Uptate your Hopscotch app
2. Restart your device
3. Buy a new device, yours might to too old to run the project


#8

Yeah it does it’s weird


#9

K it does the same for me whenever i’m trying to load a draft. I think its just a loading screen to load the objects.


#10

It mean the project is too big for Hopscotch to handle


#11

Hi @Metros

Do you by chance have an IPad Air 2?

Projects turning white after they initially play properly is most likely this bug related to use of a Set Text block with a variable:

It used to display a Whomp message but now the screen just goes white.

THT is aware and has tried to fix it but so far has been unable to.

Post #14 in the topic linked above shows a work around to extend to time until the screen goes white.


#12

Remove any looped set texts and Unicode characters


#13

This happened to me last year, but then it worked again after a while. This is probably due to the “file size bug” or the “set text bug” that @ThinBuffalo explained.


#14

Yeah, Unicode makes things lag my around 15 FPS, which is what I figured out in my tests


#15

Actually, here is a good way to fix it (works reliably):

  1. Save it as a draft
  2. Close (swipe up in multitasking) Hopscotch
  3. Reopen the app
  4. Copy the project.

(If that doesn’t work, do step 4 before 2 and 3)


#16

Ok thanks guys but it’s weird still


#17

Ah, ok
Yeah, that works


(Oh, some other thing, I used to have a glitch where I couldn’t even upload drafts or publish them because they were big. Yikers!)