White screen bug when editing/playing published project

Not sure tbh. Tbh I’m just kinda confused abt what’s turning white. I watched a few seconds into the project and looked in the code, and it’s not buggy to me

So what basically do u need? I shoulda asked that srry

2 Likes

For me, the screen always turns white when the timer reaches 20.

2 Likes

@CodeHelp can anybody figure this out?

3 Likes

Ok lemme look then

2 Likes

I’m honestly not sure. I’ll tell u if I see smth wrong! :teddy_bear:

3 Likes

Not sure if hopscotch has complicated enough code to have these, but if so if it happens at the same time maybe a corrupted file…?

3 Likes

I’m not able to reproduce the problem. Could it possibly be a problem with your device?

4 Likes

Maybe. I checked, and there are no additional software updates I need to install. Could I maybe have to update Hopscotch?

4 Likes

I doubt it’s that bc it’s happening to me too (when I wait 20s in the project)

4 Likes

There has recently been a new Hopscotch update, so that could be what’s causing the problem.

I’d try updating Hopscotch and seeing if that fixes it.

4 Likes

I have hopscotch 3.49.0 and the project works fine for me.

4 Likes

In that case, I’m not sure what the problem is being caused by.

3 Likes

I think it’s just a glitch. Try making a random change and publish it again and again. That usually works for me. I also had a white screen and it was caused by variables or something like that. I have like the oldest IPad and I usually don’t need to update Hopscotch for the code to work.

4 Likes

I just checked, and it appears that the app is up to date for me.

I’m going to see if the bug persists.

EDIT: I tested, and the bug persists.

1 Like

Did you try what I mentioned above?

1 Like

I took out the timer variable and the sprite that handles it, but it is still happening.

3 Likes

Try duplicating the project.
Edit: Could you also send me a link? The one above doesn’t work for me.

2 Likes

That didn’t help. :disappointed:

2 Likes

can you republish it?

3 Likes

The issue probably occurs because your device is running out of memory (RAM, not storage). Since the iPad you specified has 2GB of RAM and most newer iPads have 4-8GB, that’s probably why you’re experiencing the issue, and not others.

This tends to happen when you have large images, and I do think the excessive memory usage is a Hopscotch bug. I can’t really confirm anything unless you link the project, though.

Edit: looking @ link.
Edit 2: Yep, same thing happens on my iPhone 8, which has the same 2GB of RAM.

3 Likes