When Pressed Not working, trail color not appearing


#1

Hello! I was coding this morning and my project froze up, so I reloaded it, and the green grass behind everything disappeared and I couldn’t interact with the buttons done in the corner to scroll around the screen. I reloaded Hopscotch and it was fine for about 5 seconds, but then it started glitching again. Here’s a screenshot. Before Bug

After Bug

UPDATE
When I tried to load this project, it kept slowing down, then the frames hit 0 and when I hit the reload button, the games dosent reset at all, and nothing happens.


#2

That’s really weird. Have you tried to add “wait” blocks before drawing the first trail, if the bug occurs when you start the project?


#3

It starts out fine, but everything slowly get slower than stops over the period of around 10 seconds or so, then everything stops, but I still have perfect FPS. I verified this with my little fountain in the center of the area. It stopped completely, but there’s no lag when pressing the reload button, and when I do press the reload button, it seems that none of the variables reset, as the screen dosent move back to default position, and the background becomes white, and none of the buildings reload.


#4

@hopscotch-curators @Hopscotcher, Help please.
(i put this is the wrong category, it’s bugs in player btw)


#5

Hmm, that’s odd…
Is the code still there?

Maybe it’s like some bug I found where sometimes my code doesn’t work…


#6

Yes, all the code works, the problems are all in the player.


#7

Responsiveness of the reload button doesn’t mean the project has prefect FPS. If the fountain should be moving but stops, that indicates the FPS had dropped.

Suggestion #1 - Add a FPS meter to directly confirm the frame rate. Do you know how to do that?

If it takes something like 5-10 seconds to freeze up, that could possibly be a run-away cloning situation (more clones may be created than you realize. If a project gets in a loop where it’s continually creating clones, the project will likely freeze up after a few seconds)

Suggestion #2 - Add a text to monitor the idevice Total Object (global variable) count. Do you know how to do that? If number gets really big (4096 is the most possible), then that may be your problem.


#8

Thanks! I made the FPS meter, and confirmed that the frames had dropped to 0. I will make a clone counter now. Thanks!


#9

@ThinBuffalo, well I tested it, and the total objects ended up being 212. Then, the project froze up a few seconds after reaching 212 objects. When I trie to reload, nothing changes other than the background becoming white.


#10

I was just looking at one of my draft projects and the Player is going haywire (in different ways than the problem you’ve described). This may be related.

@Ana @awesomeonion Has the Player been changed or updated recently?


#11

Yeah that would make sense. Although my other drafts are fine, I can easily see that happening


#12

@ThinBuffalo here’s a link to the project so you can see what happening


#13

I was messing around with the webplayer file a few days ago (28th maybe?) and I had it sorted by either last updated or last opened and it was saying “last 7 days”

Also, I noticed double FPS a few days ago, which was fixed after closing the project. Has anyone else noticed this?


#14

Hmm. I tried playing it twice. Both times the Player crashed (white screen) after 10-15 seconds. Hopscotch had to be restarted as restarting the project or exiting to the Editor and playing it again still only displayed a white screen.


#15

Same here. Did you get in touch with any of the admins? Also, if you went to the editor, the project would still be in the same place if you played the project from the editor after it crashed without leaving the project, and any new items or code added wouldn’t show.


#18

I don’t know. This very strange.


#19

Well, I’m not gonna give up. I spent 3 hours on the project and I am going to keep trying until it’s fixed.
@Ana @awesomeonion help!


#20

Taking a look. I did find this bug with allowing negative sizes to turn things upside down rather than going to zero:
https://community.gethopscotch.com/projects/z3iqty4kt (lots of upside down trees)

Maybe it’s related.


#21

Is there also a bug with code like not working even though it should? Because sometimes that happens to me on my iPad.
And sometimes the player gets a bit wonky and I have to exit the project for it to go back to normal.


#22

Nope, all code is working fine, it’s that the player goes crazy after a few seconds.