When Pressed Not working, trail color not appearing [SOLVED]

Thanks @AwesomeOnion, I’ll check it out.
So I took my text objects and set their size to -30, and it happened to me as well. Also, when the text was upside down, the frames never hit zero, but when I tried to reload the project to double check, the glitch happened the the player stopped working completely. Also, when I put the text upside down, one of the text objects was replaced with a black bar. (The text had said “:sunglasses:Hopscotcher​:sunglasses:’s Tape Store” before it glitched.)

1 Like

@AwesomeOnion here’s a link to the project so you can check it out. Do whatever you need to do to it.

Cool project!
This is a very complicated project so it’s difficult to figure out where the bugs are.

Can you explain:

  1. what did you expect to happen
  2. what actually happened
  3. what device you are on, (if you can print out your about page, that would be very helpful)

Even better, if you can show me a project that has the same glitch but is a lot smaller and less complex I’ll be more likely to figure out how to help you.


Ok! I’ll do that.

I am Coding this on a IPad, and here’s a screenshot of what version I was on. (The picture is on phone, but I code on iPad)

If this is isnt what you meant, let me know.
Running v3.33.0

The Goal
What I was meaning to create was a scrolling 3D top down town and landscape area. I was going to add various areas, such as a town square, a woods area, shops and markets and things, landscaping, people and animals and vehicles moving around randomly, and Houses with hopscotchers names on them around the area.

What Happened
Yesterday night I was coding this, and everything was fine, then this morning around 8:00 AM PST
I opened up the project and scrolled around the little area I had made so far for a couple seconds, then the glitch happened. The screen froze, I tried to reload the project and weird things still happened. I then put a post on the forum, etc. also, I will be making projects to see if I can recreate the glitch. I will let you all know if I can make a recreation of it.

Yes, it has happened 4 times to me before, but isn’t an issue by any means
(double FPS)

Fine for me. Here, look:

1 Like

Odd. Well, I isolated the lag and crash issue @AwesomeOnion.
Apparently the issue was in Hopscotchers name text object
It read as: :sunglasses:Hopscotcher​:sunglasses:’s Tape Shop.
Whenever I removed this object, the game was fine. However, if I add it back in, it starts glitching again. I made a project that shows this for you. Also, I think it might be the rainbow texts effect on emojis, as the variable for the rainbow text is continuously increasing. But that’s just my opinion. Also, if you keep moving the text object around, it eventually lags hard and converts to a black line.


I did some tests with that and it only crashed for me when the text had both an emoji and regular text. Either of them alone did not crash, but together they did.


Thanks PeppyWafer! I really wanna get this fixed. Was the text still rainbow while you were testing?

Yes, I reopened the project several times, and each time made a different modification. I don’t think I ever removed the rainbow effect. :grin:

I’m just glad the bug was found! Now I can continue my city project!

Yeah I got that on my bird caretaker project wip.
Some of the code wouldn’t work right, causing Hopscotch to lag on me.

1 Like

This is a version of the same bug as the increasing numbers issue. It crashes more quickly because when you have a plain text object, we can create one image and then color it.
When you have text + emoji we have to create a new image every time you change color. This allows us to get the effect of your text changing color while the emoji stays the same.
Here’s my reply on the other thread: Crashing when variable is being constantly increased


Oh, okay. I thought about putting it in this topic but didn’t think they’d be related. I was wrong.
Thanks for finding out what’s wrong so quickly!