Updating the Screen (or not)

Hey, been a while. I have an idea which I don’t think has been proposed before this point.

The story…
I was coding on Microsoft Excel. I was putting down a line of code called ‘Application.ScreenUpdating’ when I thought, “Hey, Hopscotch should have this!”

So what is Application.ScreenUpdating?
Basically, this is a built-in function that allows the viewer to be unable to see any changes that are made, appearance-wise. It utilizes a boolean (aka true and false) to determine whether it would ‘update the screen.’

Application.ScreenUpdating = True (updates the screen to show the changes that were made.)
Application.ScreenUpdating = False (stops the viewer from being able to see changes made. Changes can still be done, you just won’t be able to see it happening.)

Why should it be in Hopscotch?
If my previous (probably poorly-composed) explanation didn’t satisfy you, I will add that I think having this on Hopscotch will present the opportunity for projects to run more smoothly, since you can use it during longer loading times (either initially, or in-game).

I don’t know, what do you all think?


Obviously the term would have to be shortened since a lot of newer hsers would have no clue what that means, but this would be super helpful for smooth transitions and loading the project at the beginning of the play.


Of course; Application.ScreenUpdating is just the code for it in Excel. On Hopscotch it probably should be something simpler or easier to understand. I’m obviously not great at descriptions, so they would probably need to have more concise and easy-to-understand definition for it as well. Should they choose to use this idea, that is.


Freeze Screen

Freezes the screen. Your code still runs, but you won’t see it until you unfreeze the screen. Useful for when you need to do something you don’t want the player to see.

Unfreeze Screen

Opposite of Freeze Screen, unfreezes the screen. Use this when you’re done and want the screen to move again.

Something like this maybe?


Yeah, I think that hits the nail on the head. It could always be a boolean, Freeze Screen can be true or false.


Good point.
(Forgot to add text)
Perhaps it could be a single block with a true or false modifier? Or just a switch block to save time.


little confusing at first but after giving it a second read this would be nice to have


So it would probably be simplified to something like “freeze screen” and “unfreeze screen”. I love it.


Great idea! Maybe the name should be ‘freeze/unfreeze project’ or something instead of

Moving on to things others have not said yet lol.

This would be helpful for people who make Polyart, and maybe 3D rendering because if the screen was frozen no one would see the shapes forming and things might look better for the coder (depending on how they want their viewers to say it. This would also help cleanness . Thanks for the amazing idea!

1 Like

So basically a screen freeze/unfreezer
That’d be cool actually