Time Zone bug in Hopscotch


Use this template to make awesome bug reports:

Your username: FluffyMice! (Another Bug- When you search for my username is doesn’t work. Instead, Just search “Smoothie Maker” and the first project should be mine) P.S my username has an exclamation mark at the end because someone stole my username when I changed for five minutes. I looked at those people and they are not active on hopscotch so would you mind swapping my username with them?

What kind of device are you using?: iPad Mini 4

1 sentence description of the problem (I was doing _________, and then __________ happened): I came from Hawaii to Australia and I changed my iPads time. I posted new projects and they all say from 2 hours ago

Steps to make the problem happen:

  1. Change timezone
  2. Publish a new project

I expected this to happen: The project would say something like “Published 5 seconds ago”

But instead this happened: “Published 2 hours ago”

Here’s a sweet screenshot:


Infact, Everything is doing that




I remember that Hopscotch had a problem like this with the old editor a few years ago, and they changed something to fix it. Maybe they have to do it again. Thank you for reporting this bug!


It’s getting very weird now. Half an hour ago it said that T1 had liked A few of my projects 50 minutes ago. Right now it says she liked them 15 minutes ago
EDIT: it now says 9 min

EDIT: oh god, it’s everywhere now! Even on the forum. What the heck? I’m restarting my iPad


Well, this is teaching me science! Two hours is apparently less time then nine minutes


I’m pretty sure I know why. I believe that there is a bug where unseen activity will remain at the top if you don’t clear your notifications, and they rise. This is my theory…


This happens to me all the time… I emailed the HST and they fixed it


I found the solution. I scrolled through the numbers to make my iPad the right time. But it was still set to Honolulu time. Its fixed. And so is my instagram XD


That’s weird.


Woah! Someone that saw this topic fixed it!


That is so annoying!


Someone fixed it somehow! It’s awesome


Oh great!

shall we mass spamlike someone


Who…? XD