This Siri Shortcut Can Modify your Projects | ๐“๐”€๐“ฎ๐“ผ๐“ธ๐“ถ๐“ฎ_๐“”

Hmm okayโ€ฆ

Well then thatโ€™s not true. What I meant was that if you made changes, the local variables could have still stayed there when saving back to the app.

You can use the search function in the project builder to search for blocks that use the local variable

As in โ€œWhen I will finish adding support for custom rules and saving projectsโ€

1 Like
tried to open a project with local variables lol

@Awesome_E, does the project builder allow importing presets into a project opened from a link? Iโ€™m having trouble with that


edit: now i have trouble with that too :(

I thought you should be able to but apparently I didnโ€™t allow all file types and iOS doesnโ€™t let you specify specific extensions for some reason. Thought I did.

1 Like

Interestingly enough, I think thatโ€™s the result of having two things outdated:

  1. Block names in block rendering: โ€œnotโ€ doesnโ€™t exist there, so it has the block and parameter descriptions (I think both the block description and parameter key are โ€œnotโ€, so it becomes โ€œnotโ€ + โ€œnotโ€ = โ€œnot notโ€)
  2. At the same time, I think my webplayer doesnโ€™t support the โ€œnotโ€ block, so it just doesnโ€™t run it. Not entirely sure on that but I would have to check again.

Plus, local variablesโ€ฆ

Yeah the rules with the not operators donโ€™t run at all on your player.

I already know about the incompatibility of local variables on your player, and I saw how crazy and broken it gets, especially with my newer platformer. I changed them all to object variables for the purpose of something else :eyes:

1 Like

I knowโ€ฆ I should eventually move to an API that can automatically grab the latest HS player and apply my mods to it

1 Like

Less than a day later (:sweat_smile:) โ€“ done.

Webplayers should now be in sync with the latest production version from Hopscotch at all times. Modifications are made on the fly when you use my modded player at any given time.
(this also means that local variables and other features that werenโ€™t added yet are now supported in the player)

@Good-Es

11 Likes

Thatโ€™s so Awesome(_E)

I am having a bit of trouble loading my game on your player. Was trying to test out the newly added controls.

It says โ€œsorry, unavailable. try again laterโ€ (similar to that error) on my side. It does load in the project statistics, at least.

Controls: (PS4 / XBOX)
(R) = scroll
Options / (โ‰ก) = play/edit level
[L1/R1] / [LB/RB] = previous/next tile
[L2/R2] / [LT/RT] = previous/next tile category
D-pad Left/Right = Move Player
(X) / (A) = Jump

Edit: Tried doing a Force Restart with no luck.

1 Like

@Awesome_E It seems only the projects with literally only 1 function will load on my end, but any more than that, and it will return the error โ€œSorry, try again laterโ€

I am 100% certain I am connected to the Internet.

And my project being tested was less than 1 MB (about 700 KB)

1 Like

My bad, accidentally made a blank substitution go in as undefined instead of empty string. Just pushed a fix, and it seems to be working now.

2 Likes

Yep, I can confirm itโ€™s working again.

1 Like

Even better. My older game is finally working on your player. It actually defines the level dimensions this time.

I did get a glitch where absolute value(-1) would turn into absolute value(-1)( ) after evaluating math operators in your player.

It affected round, floor, ceiling, sine, cosine, and absolute value.

1 Like

Forgot to mention,

The official comment block will also let you run modded player actions in my player!

Since text in multiplication is always interpreted as zero, the multiply block will always be zero in vanilla Hopscotch.


But, what if in the modded player, I could evaluate a webplayer action instead of doing the multiplication? Then itโ€™s still either 0 or 1. (This would only happen when the text starts with _ae_webplayer_action:

Pros:

  • no reliance on secret blocks
  • can drop in any number slot

Cons:

  • can be really confusing since multiply is so seemingly random, though ยป isnโ€™t much betterโ€ฆ
  • unforeseen consequences. If the behavior of multiply gets changed, this could be affected, albeit only with strings that start with _ae_webplayer_action:
  • Interesting, I would really like to see this!
  • Maybe notโ€ฆ
  • I have feedback (please reply)

0 voters

@Good-Es

5 Likes

To be honest I donโ€™t care how random it is, Iโ€™m too lazy to get secret blocks lol

Actually Iโ€™m so lazy I feel _ae_webplayer_action: is too long

2 Likes

Me too. I use a text replacement, which you can set up in your keyboard settings. That syntax is really to make sure you donโ€™t accidentally have a string that causes it to think itโ€™s a webplayer action

Settings > General > Keyboard > Text Replacement

[your string] โ†’ _ae_webplayer_action:{"name":"NameGoesHere","args":[]}

2 Likes

I just made a few replacements for the controller input webplayer action

/m0 โ†’ _ae_webplayer_action: {"name": "checkControllerButton","args": [0,0,0]}

m0 = mode 0. I have 1 for modes 1 and 2 as well

I also added ae_default, which returns a blank webplayer action (basically the string you mentioned above)

1 Like