The Topic To Share About Bugs In Hopscotch

hopscotch
bug
ifoundabug

#1

I think we need to share some of the many bugs roaming around hopscotch. In no way do I mean to criticize THT, only help them catch these bugs and improve hopscotch. If you or your friends have experienced dangerous bugs others need to watch out for, please share them here.
@Liza, @asha, @Ian, @Meg, @Kiwicute2016, @PopTart0219, and @BuildASnowman, I think you should check out this topic.


#2

I think there is a topic about this already, just make sure to SBYP next time. :smile:


#3

Nope, they are all about a specific bug. Here you can post everything you come across, instead of making a new topic. Anyway, TFYC!


#4

Liza made a topic to accounce bugs and suggestions for the new update I think. :smile:


#5

I only found this by Liza:

http://forum.gethopscotch.com/users/Liza


#6

@liza pleas help When I publish a project from my ipad I can only see it on that account! I wonder if I got reported? I never publish anything inapropriate. I went on to my friends account and published something, but it diddnt show up on my other accounts! Please help, @liza @ian and @Meg


#7

Thanks for letting me know! I fixed this problem and you should be able to publish normally :slight_smile:


#8

Thanks @Potter_Head! I know you guys are eager to get bugs squashed, and you can help us by making sure your reports are ready for our investigation :spy: :spy:. Please include:

  1. Exactly what you was happening when you experienced the bug (even better are steps that we can take to reproduce it)

  2. What you've tried to do so far (like restarting your iPad)

  3. What kind of iPad and iOS you're using

  4. If there is a problem with code not running, include a screenshot of your code

Also keep in mind that sometimes what seems like a bug might actually be something else, like a bug in your logic :rolling_eyes: (we've all been there!). For example, your code doesn't work because you put something after a repeat forever block.

Thanks a million billion!
Liza


#9

I have a bug to report:
When I do need to use the hopscotch colors, sometimes they don't work. It usually happens with the grey or the green, but randomly they stop working. The shapes don't change color, they just stay black and don't do anything.

I've tried restarting my iPad, deleting and reinstalling hopscotch, and restarting hopscotch, nothing worked.

I don't know exactly, but I know I have a version of iPad Air.


#10

Hm, I've heard this with the light grey color before but I think we fixed it. Are you running the latest version? Is this still happening? If so, can you post a screenshot of the code?

Thanks!


#11

I do have the latest version of hopscotch. Here is the photo of the code when it last happened, but for some reason it happens sometimes, then works other times.


#12

Google: Did you mean Thanks a quintillion?

Lol sorry!!
Le XD


#13

There's this weird glitch. This is how it happened to me:
I grabbed out chevron, turned it 30°, and then colored it red. For some reason, when I hit play, it the size became ~50%, and when off to the side. I believe this happened with other colors too.


#14

@Dude73 @Liza this happened to me 2 nights ago, and I'm updated.


#15

Hello! A huge glitch I've noticed when coding on this app is some of the shapes provided by the app don't change to the colors provided by the app properly. They often stay pitch black, or sometimes even change position, size, and rotation back to how they are at the start of the code. I've tried putting each command in separate rules, timing it strangely, and other. And no, I don't currently have screenshots, but I am sure many other users know what I am talking about? Are you guys working on this, @Liza? Thank you..


#16

Help! @liza, I found a really bad bug. It duplicates everything in my project! I was working on it, went to check trending, then came back and this happened!


Any way you can fix this and get my draft back?


#17

@Liza I fixed it, but can you see : if you can stop it in the future?