Spiral emoji draw not working!

Use this template to make awesome bug reports:

**Your username: Cktennis **

What kind of device are you using?:Iphone 11 pro

1 sentence description of the problem (I was doing _________, and then __________ happened):I was making spiral emoji draw but it was soooo laggy

Steps that the Hopscotch team can take to reproduce my problem every time:
1.make spiral emoji draw
2.play project
….

I expected this to happen: I would have a cool game

But instead this happened:it laaaaaag :frowning:

**Here’s a sweet screenshot:

**

7 Likes

Anyone have this bug?

2 Likes

That more a problem with excessive cloning than a bug in the app. The more objects, the worse the lag will be. There is a certain peek to the amount of objects before the lag becomes noticeable (where if you remove one object it all of a sudden becomes smooth again).

3 Likes

Soooo why did this work in the old editor AND other projects

And why is it a vid if they know it doesn’t work

2 Likes

IDK. I had no trouble with lag on iPad8,1

Also, a topic on lag on newer versions has already been reported on the forum.

2 Likes

That vid was probably made BEFORE the latest 1.5.x version

2 Likes

It has been a glitch for a while (like a year-2) but ig I just forgot about it…
old editor meaning 2016 lol
Idk why it worked for the guy in the vid

2 Likes

Why do I feel like bugs reported by leaders and regs always get fixed… I had to go to the HQ to get my idea down…(before the forum)

2 Likes

Well imma code something

2 Likes

it’s probably your device.

2 Likes

It doesn’t work on my I pad eather

it’s probably your device

Does it work on yours?

haven’t tried, but clones can cause lag on some devices

@Cktennis5, is the create a clone block inside a “check once if self clone index = 0”? Without it, cloning the original object will also clone the clones it cloned.

Also, the vids were never updated for the latest version (unless they are brand new). It was probably from 2016 where you had no issues…

2 Likes

a link would help

1 Like

I don’t think the project was published yet…

If the draft is from an old version, use “self clone index = 1” instead.

Did you use “destroy?” I always use destroy when I am using clones, but jt makes it hard for a restart button lol

1 Like

I’m pretty sure the vid tutorial was made before the destroy block became a thing.

1 Like