Shapes Not Working [OPEN]

Use this template to make awesome bug reports:

Your user name: FearlessPhoenix

What kind of device are you using?: iPad

1 sentence description of the problem (I was doing _________, and then __________ happened):

I added a circle and 2 blocks of code, and played the project. The circle didn’t do what it was supposed to

Steps that the Hopscotch team can take to reproduce my problem every time:

  1. Go into the editor
  2. Add any shape
  3. Add some random code to the shape
  4. Play it
  5. Shape will be gone
    ….

I expected this to happen:
I expected the circle to go to the center of the screen and then set its size to 200, like the code said

But instead this happened:
The circle never appeared on the screen

Here’s a sweet screenshot:

@Ana, @Awesomeonion, @rodrigo, @codehelp @fearlessfriends


I was trying to make a shape art but that’s kinda hard to do if the shapes don’t show up lol.
Text objects, images and characters work like they should.
None of the shapes do.
It can be any shape in any project and it won’t work. For the bug report above I did a circle in a new project but any shape in an old or remixed project doesn’t work either

16 Likes

Here’s a link to the test project whose code is shown above, it should be filtered (on purpose)
https://c.gethopscotch.com/p/108pzgmklc

8 Likes

Hmm, and you have AE’s web player on your iPad too?

4 Likes

It worked for me

Also this is BROKEN, it should draw a blue BG
https://c.gethopscotch.com/p/108q13bbb6

2 Likes

Yeah I do.

2 Likes

That’s odd.
What version of hs do you have?

I have the lastest version on both my iPad and my phone. It doesn’t work on either of those devices from any account for me

4 Likes


Same exact code as you showed, no issues

4 Likes

Works fine for me
Try setting image circle maybe?

3 Likes

Works for me too

Fea have you tried using an alt acc and clicking on the link or using another device?

3 Likes

Yeah and it doesn’t work…

2 Likes

Hmm

Lemme try one thing

1 Like

Hey does this work?

https://c.gethopscotch.com/p/108q4adzwb

1 Like

Nope.
I can see it in the thumbnail and editor but not when I play it.

And in the iPad collab that spe, Tankt and a couple other super are doing, I can’t see the shapes making the border of the iPad or the home button etc in the player but I can see it fine in the thumbnail

3 Likes

This is strange! Maybe instead of (width / 2) and (height / 2) you should say (512) and (384).

If this doesn’t help, it’s probably just a bug that can be fixed by closing down the app and reopening it.

1 Like

Fixed it


It can’t start by drawing a trail in an exact pos

2 Likes

This usually happens to me when I have bad internet even if I have three bars. Maybe it’s an iPad thing bc it’s happened to me tons of times

Works just fine? You saved the file to the right place?

iPad \ Hopscotch \ webplayer \ versions \ 1.0.0 \ webplayer.min(.js)

3 Likes

Newest I guess I have 3.34.0

1 Like

i’ve Done that before I think, anyways, thanks

1 Like

Are you using AE’s update fix?
Maybe the shapes were changed in the latest HS update, and the update fix changed the shapes to the pre-update shapes, and now the shapes won’t appear because of that or something?

4 Likes