Shapes becoming invisible in player when visibility isn’t specified in code


This is a problem that I have been expriencing recently. Because of it, I have had to restart coding a really big project of mine and that wasn’t fun.

I have been coding this on my iPad mini 4 and I am using the latest update of Hopscotch (Version 3.21) and iOS version 11.0.1 (not the latest cause they just realised a newer version)

What happens in the bug:

When using shapes in my projects, logging in and out of my account causes the shapes to disappear while playing the project even when there is no rule specifiying that the object should be invisible.
Pictures of the project (code included)

in case you are wondering, I have in fact pressed play game

I have added in the invisibility/visibility blocks after I discovered the bug to see if it would solve the problem. It doesn’t appear to have done so.

The only way I have been able to fix this bug is to delete the shapes that had become invisible and also duplicating the project as otherwise all new shapes I would add would automatically become glitched.

Could we look into this perhaps?
@Liza @Rodrigo

Thank you :)

Disappearing Objects
Set Text causes "Whomp"

Do you know if you could publish and unpublished it (give us the link) because I think I might try and fix it :smiley:


Oh umm…
I kinda got rid of the bugged copy and debugged like how I explained up there already…

Yeah, I might try replicate the bug tomorrow.
I’ll tag u on this topic if I end up doing so


Hmm thats really weird
I think I’ve seen a similar issue on a topic lately?? Hhhh i forget where it was
Sorry I don’t think i can help; its not really your code thats buggy


I experienced this bug too…


I experienced that bug too!
I was playing a game though and then things started disappearing. I checked the code and nothing was supposed to disappear


This is really weird and I hope that THT will fix it soon.


@Dolphin_coders here you go
This is a different project to the original project. When I originally tried to replicate this bug I thought it hadn’t worked (still not completely sure if it did). I added in a shape and poof, the bug appear.

I also encountered another bug while making the project… should I report it on here or make a new topic


This is an absolute bug. There is no solution that I know of, besides using a text to represent a square: ▉


Thank you for your suggestion :)

At the moment, another way I have found to fix the bug, as I stated in the first post is to

I do also have an keyboard that has those shapes so I might use them in the future


I have the issue as well, I’m working on troubleshooting it. I’ll let you know if I find a solution. Did you delete any drafts before you noticed that the objects were turining invisible? My thread: Disappearing Objects


Hello there! Interesting to see you have this problem as well.

I hadn’t deleted any drafts for a while before experiencing this bug from what I remember. It was a while ago so I don’t remember much.

Thanks for letting me know tho :)