Set Image Block Bug?


#1

For people with a HS subscription:
In one of my projects, the new “set image” block sometimes won’t change the image, but other times it will. Has anyone else experienced this or know why this is happening?

Thanks!


#2

I do not have a Hopscotch subscription, and I cannot afford one, so I was afraid that I do not have any experience with it.


#3

Ok, thanks anyway! :slightly_smiling_face:


#4

I’ve no subscription but can you show a screenshot of your code? I know a few bugs with set text and they might be the same.


#5

Anyways, do you care to enter my story contest? It’s in my “Story on the Forum” topic.


#6

I just used the set image block as I normally do.


#7

Try getting rid of self and replace it with original object. 7 = 7 also works for clones… so.


#8

How do I enter? :upside_down_face::smiley:


#9

Where did I use “self”?

EDIT: Ohh I see now


#10

You enter by voting for a story.


#11

You used it for the variable image. Try either original object or the actual object.


#12

@Madi_Hopscotch_, if you didn’t know there is a bug discovered by @Thinbuffalo that was alarming as a looped set text would cause a crash. It took about 60 seconds for the crash to occur. Earlier today, Awesomeonion had edited the code adding a small wait inbetween each frame calculation with the set text block (and I believe so with set image too) so frames are calculated slower so it is possible that due to the edit such codes like set text & set image are not appearing.

Here is another bug Report:


#13

The Set Image block works for subscribers as well as non-subscribers.

Can you post a screenshot of some of your other code, where you set the Image variable?


#14

I doubt that. I saw her code and everything looks fine. I believe that it is the changes awesomeonion did to set text & set image, because I’ve seen other bug reports like this.


#15

I wonder if i can go to an archive of the hopscotch webplayer and inject it into hopscotch app


#16

That’s probably not allowed. I only think THT can do that.


#17

if you do the json thing i think theres a webplayer js file so its only a local change

lol no i wouldnt hack something like this, on a global scale

idk


#18

@BlastFusion so if it is because of awesomeonion’s change, Is there a way to fix the problem?


#19

We should wait until Awesomeonion has fixed it. For now, you should try removing the loop somehow and it should work fine.


#20

The problem is that most of my code in that project involves those loops… :joy: