Problems on 1st play when loaded from link (OPEN)

I’m encountering a situation where a project plays differently (some of the objects don’t seem to have loaded correctly) the 1st time a project is played from a link.

I’m aware that a project’s starting FPS is different on restarts. Therefore when projects use Wait blocks, the results due to timing/sequencing differences may change. For that reason I rarely use wait blocks other than Wait 0 (which should delay 1 frame regardless of the FPS). This is a different problem.

Before I submit this as a bug, I’d like to know if anyone else has similar issues with this project

If you’re willing to test, play the project from the above link. Only on the first play, the inside of the house doesn’t render correctly. I’m seeing


Where it should look like this (note the “doors” between the rooms)

On the 1st play after loading from the link,

  • The project (doors inside the house) looks right
  • It doesn’t look right

0 voters


I would test but HS is down atm


Yup that is how restart detection works


Really cool project but a weird bug! On my Acer laptop with Windows 10, I got this weird render on the first play after opening the link in Google Chrome:

And it looked like this (which is correct) after restarting it once:


I tested it and there weren’t any doors.
I also found that if I moved back and forth once or twice inside the house it switched to showing the roof when I’m inside and the inside when I’m out.


Odd. 6 ppl responded to the poll so far, but the link only indicates that 2 ppl clicked on it.

1 Like

It worked fine for me (in the app), on my family’s 6th gen iPad.
Though I did have to tap the link 3 times to get the project to show up.


This seems to be an issue for me too

When I use change pose, the object just blinks invis to visible for a few times

1 Like

Chrome tends to be the worst option for hs sometimes

See this:

1 Like

Well I tried the project in hs app and the bug still occurs…

1 Like

I tried it on the web player on my iPad and got the render without the doorways, and the render where the gray part is short in height.

1 Like

Recategorized as ‘Bugs with Player’

@ana @awesomeonion
Please see original post. I’d speculate objects aren’t loading correctly. And it seems pretty consistent with most polled users reporting this occurs for them as well. I don’t know what would be unique about this particular project though, since I don’t think this occurs with most projects.


This seems extremely odd and annoying because you might think that there was something wrong with your code. Also, with the screenshots, I recommend that instead of the (281x499) you do this: (281x499, 50%) and then it will take less scrolling through the images.

Also, with the actual gameplay, when you walk sideways across the area which you go into the house from, the roof still toggles, and that means that when you walk in the roof appears and when you walk out, it disappears.

1 Like

Hmm. That part is definitely just a bug in my collision code at the door. I’ll check it out. Thanks


@ThinBuffalo, I have a similar problem

The countdown bar always shrinks oddly on the 1st play but everything’s fine on restart


1 Like

Hi there! Do you still think its a bug or you were able to sort it out?


I think this is still going… it says “(open)” on the tittle lol

1 Like

I put ‘Open’ because I’m not sure if it was solved.

Do you know anything about this issue?


Well more less… I think that when a project with certain characteristics (idk what) is first loaded, the game doesn’t load properly, honestly it has happened to me and I think it has something to do with the JSON or the webplayer

It’s still happening.

I went into the link in the first post and it did exactly what William saw in this post.