Player stuck on white screen :/


#1

Your username: MR.GAM3R​:video_game:

What kind of device are you using?: iPad Air, running iOS 10.3.1

1 sentence description of the problem (I was doing _________, and then __________ happened): I tried to play one of my drafts but it just got stuck on a white screen.

Steps to make the problem happen:
1. Do some stuff in the editor
2. Tap Play
….

I expected this to happen: The project will play normally.

But instead this happened: It got stuck on a white screen.

Here’s a sweet screenshot:


This bug has been killing me lately! The only way to fix it is to exit the project then go back to it. However, after a while the white screen will come back. I wouldn’t mind it so much if the “file size bug” wasn’t a thing, which makes a project get laggier every time you open it. This bug has been making it very hard to do anything in my draft. It has quite a lot of code and objects, which is probably it is affected by the bug but other smaller drafts are fine. The white screens are an issue on v3.18.0, v3.16.0 and I assume v.3.17.0 as well (although I have not tested it).

@Liza @Rodrigo @awesomeonion


#2

I recommend doing ng the thing I said on your testing thing and doing that. That's what I had to do with Arctic Rooster.


#3

Will that not make the player get stuck? Don't quite see how that will work.


#4

Yes. It should.


#5

Doesn't seem to work when I tried it. I added the text object and the Set Text block.


#6

Hey MR.GAM3R you say the file size bug happens every time you open a draft?
Which draft is it? I know we have had a lot of complaints about this, but
we've actually had trouble reliably and systematically reproducing it. If
you have a particular draft on your account we can look at it that helps!

Sam


#7

To add on to @awesomeonion can you give us a little more detail about the first step—adding stuff to the editor? When we test this, we're not getting the same result but probably not adding the same stuff as you.

Can you take a video of yourself adding coding to the editor so we can see when it starts to slow down? (Even just having a friend take a video on their phone of you coding on the iPad would be hugely helpful).

Thanks!!


#8

@Liza, same thing happened to me a while ago, when I was adding some clones in one of my games... :confused:


#9

Oh no! Can you try to make it happen again and record a video of it? Do you mean just adding a clone as the first block or did you already have a bunch of code there?


#10

There was like 250 clones...
Edit: it works perfectly fine! I'm confused :0


#11

Ha ha

“Here’s a sweet screenshot”
There nothing but white xD


#12

@awesomeonion @Liza The first post isn’t about the file size bug, it’s about the player getting stuck at a white screen. Anyways, the draft I’m talking about should be my most recent draft, it’s called “Hoop2”. The file size should increase every single time your open a project in Hopscotch.

QuickTime isn’t working for me at the moment lol. Don’t know how well a screen recording can show the file size bug though. Will try restarting my computer in a bit.