"Open In App" Button Does Not Work


#1

Your username: Rawrbear

What kind of device are you using?: I am using an iPad Air 1.

1 sentence description of the problem (I was doing _________, and then __________ happened): I click on a link to a project, and when I would tap "open in app", the app itself would open, but the project would either take forever to load (it would take 10-20 seconds for the thumbnail of the project to appear on my screen), or it wouldn't load at all.

Steps to make the problem happen:

Click on an hssample:// link that would link to a project. (I tried to open @Periwinkle_Dolphin's Ultimate Drawing Pad through the browser. It's this project, and this was the hssample link:)

hssampleproject://?http://community.gethopscotch.com/api/v1/projects/yc8stytqe?user_id=451769

Then, the app would open, and nothing would happen, or it would load for a while, then show the project thumbnail.
….

I expected this to happen:

The project's thumbnail would open.

But instead this happened:

Nothing would happen; it would stay on the featured page.

Here’s a sweet screenshot:

Note: the top "OPEN" button works fine for me, it's just the "Open in app" button that doesn't work.

Does anyone else have this bug as well?


#2

Hmmm... that doesn't seem to happen to me...
What version of iOS do you use? What version of hopscotch do you use?


#3

It's most likely that you have to update the app.


#4

I'm using normal iOS 10, with the latest version of Hopscotch, I'm pretty sure.


#5

Check the App Store to check for any updates

The notification badge doesn't always show up on the app store


#6

I'm using Self Service, an App Store that doesn't auto-update. I will try later, thanks. :)


#7

It sometimes happen to me.
You have to wait for a while
OR
Refresh the app


#8

Try going back to the forum and clicking it again


#9

Did that already a bunch of times.


#10

Maybe close the webpage


#11

I know this happned to me like right now!M


#12

Just happened to me. Maybe it doesn't always work.


#13

Why did it take you to that page anyway? It never takes me there.


#14

Takes me there for me. Weird, isn't it?

It still doesn't bother me too much, though.


#15

Thanks for reporting. Will take a look!


#16

This is not part of the topic but I want to permanently delete a topic?


#17

How do I do that?
I just sign in recently and some guys told me that my topic wasn't a hopscotch topic, so I need to delete it.


#18

I have self service too!
What grade are you in?


#19

I'm in eighth grade! ^^


#20

Who was your seventh grade social studies teacher?