Only when refreshed, set background works

Your username: Creation Productions

What kind of device are you using?: (Also include iOS version, and Hopscotch version)

1 sentence description of the problem (I was doing _________, and then __________ happened): I was coding my game and wanted my game background to change to ‘grey’ every time, but instead it turns to white like default until refreshed again

Steps that the Hopscotch team can take to reproduce my problem every time:

  1. Create a project with ‘set background colour to’
  2. Bug occurs

I expected this to happen:
Background change to grey
But instead this happened:
Background is default
Here’s a sweet screenshot:
Perhaps a link with video instead?

@/TeamCreations

5 Likes

Yeah it’s a bug that’s been here for a while – trails drawn on the first frame also tend to get erased on first play, so it’s really the same bug as this:

1 Like

For the other bug report, it specifically happens if there is a movement block after the Draw a Trail with Set Position — if there is no movement block afterwards, or the block inside the Draw a Trail is not Set Position, it will draw the trail correctly when the game starts.

And that bug persists even after restarting the project, whereas this one seems to be on first play only. I think we can merge if they’re confirmed to be the same cause — they might be slightly different causes.

2 Likes

2 posts were merged into an existing topic: Draw a trail with set position does not work as first block (OPEN)