Okay... what? Block not triggering for no reason


#1

What is going on here?
https://c.gethopscotch.com/p/100vfm12yw
This rule is not triggering, for no reason at all whatsoever when the clones’ ‘Base’ variable equals -0.1!


@CodeHelp


#2

Are you in a team for Hopscotch March madness? And I have no clue what’s going on here but I will come back to you with the answer to your problem.


#3

@MISSION_IMPOSSIBLE this is a tough one! I have no clue what’s going on here but to be honest I’m not too great with this sort of code.

@Awesome_E
@Funky_63_Greenland
@CreationsOfaNoob

These people may know what to do! :point_up_2:


#4

Yeah. Why? It is a bit weird though. You can see that the ‘people’ moving around show their variable and at the end one of them says ‘-0.1’. It is weird.


#5

Try using a different block set up, like
WHEN GAME STARTS
REPEAT FOREVER
(CHECK ONCE IF BASE= -0.1
SET POSITION
SET BASE)


#6

See if that helps or changes anything


#7

That’s weird. I believe it has happened before, and that it is a bug. Why aren’t you using whole numbers though?


#8

Tried that.


#9

Whole.


#10

I mostly am. I am using this to check if it has returned to the tee.


#11

Hoops. Must’ve been autocorrect.


#12

Sorry dude, I’m not really sure about this.


#13

:slightly_smiling_face: So, I really like your projects. I wish I was like you. An aammmaaazzziiinnnggg Coder. I have made one of your projects be featured as I nominated it.


#14

Yeah. It is weird. I have tried restarting everything as well.


#15

Oh, I figured it out. The variable isn’t even changing for some reason


#16

It IS tho. If you go into the project, press the circle 4 times slowly, you can see the players line up in order. The first is -0.1, the second, -1.1, etc.


#17

I made a text object, put when 7 =7 set text to base, and it stayed at 0 the whole time.


#18

It is a self variable. It needs to be in the clones, for it to change.


#19

Wait, it’s for the clones, correct? I think the problem is that u didn’t put the object is cloned block


#20

I did. Have you even been in the project? Sorry, a little frustrated.