No published projects open on Hopscotch

I can’t open any projects with Hopscotch, all it does is say “Whoops, we couldn’t download the project!”

  • I have it
  • Nope, it’s working fine

0 voters

I see others have this problem, which is why I created this

drafts open fine though

10 Likes

Same issue here as well. It was broken for me a couple weeks ago too in the same way but that was a problem on my end. Seems like this one is something with hopscotch

5 Likes

Ah I see. I’m not the only one with this issue.

4 Likes

I have this.

I also have an issue where, when attempting to open a draft, a blank project that is not the right editor size (just the editor size of the device) appears and then the project deletes itself. Didn’t lose any really important stuff but it’s annoying. It happens on my phone, idk if it happens on my iPad or if the drafts seemingly deleting on my phone also delete on my iPad. Soooo be careful and open a useless draft first to check if you have this deleting-draft issue before opening a draft you actually care about.

6 Likes

ok so the kaleidocosmos apparently all projects json api is weird
doesn’t have rules and stuff
http://c.gethopscotch.com/api/v1/projects/xii9vn8sh
I think that may be the issue?

4 Likes

that seems like a pretty big issue lol

3 Likes

The same thing is happening with my player.

The reason is because the api/v1/projects/<PROJECT_ID> isn’t returning an objects array for any project.

Yep, I believe this is also an effect of the same issue. Not sure if it will happen with drafts that are already on the device, but it will definitely happen to any drafts that aren’t synced locally (ones that you changed on another device and have to download)

6 Likes

Let’s hope the major server crash is resolved soon. This is the second time this happened to me.

5 Likes

The last published projects in newest are all hours old too btw, might be related?

5 Likes

Wait I’m not the only one with this? Yaaay.

5 Likes

It probably is related – hopefully it is just a server bug, and not a data loss (that would be really really really bad)

It seems though that the issue doesn’t just apply to the objects array, but actually anything that has an array:

  • Objects
  • Rules
  • Abilities
  • Custom Rules
  • Custom Objects
  • etc.

(the one exception being remote_asset_urls)

5 Likes

@tankt2016 yep, same with me, a good procedure would be to not open any drafts on iPhone until we have a confirmed fix

2 Likes

I have not encountered this problem

3 Likes

I have this problem too:


It happens a lot. Is fixed after exiting then re-entering the app a bunch.

2 Likes

ah, it’s not that one—this is one where you literally can’t play projects (the community loads fine)

2 Likes

Just gonna quote some Yuanyuan posts here real quick :))

1 Like

Oh huh. I think I have that one sometimes too. This one more though.

Edit:

Yes I am having that bug right now.

1 Like

UPDATE: The issue has been fixed

(confirmed by AwesomeOnion, and I can also confirm that I am able to play projects again)

^ @Leaders

1 Like

Issue was found and a topic was made