Nested conditionals don't work and conditionals inside of abilities don't work

bugs

#21

Good to confirm. It seemed like an update to the Player (webplayer) would be the cause since it changed for everyone without an app update. Still it seems odd that the player isn’t broken for draft projects. I’m curious to see what the explanation is if @awesomeonion gives one.


#22

Oh no!! Fixing it now. That was a bad deploy


#23

Oh, ok I got confused. This is an old bug. I never knew about it before.


Hopscotch is ruined
#24

Hi @awesomeonion!

Thanks for fixing :slight_smile :slight_smile:


#25

@awesomeonion Hi Sam. No, this is a new bug that seems related to a recent update of the Webplayer. Many published projects don’t work any more.

It’s caused by nested conditional blocks not evaluating correctly (as opposed to some conditional rules inside nested custom rule blocks not evaluating correctly which was a pre-existing bug)


#26

Ah thank you, nothing was working at all


#27

Is it fixed now? Which projects don’t work?


#28

@awesomeonion
Nope, not fixed. At least not for me.

As one example, this doesn’t work anymore:

Note the cover image & the project when played now doesn’t have the keyboard or text arranged correctly.

————————

As another, and much simpler example, here’s a project with the code shown in the OP

This is the code, so obviously it should display “Working”

I just created this project. It didn’t play correctly as a draft or as published. Other drafts that I have (that existed before the recent webplayer update) play correctly, whereas published versions (e.g. the text adventure linked above) do not play correctly.


#29

Ok. I deployed what I think was the previous version. Let me know if it’s working now.


#30

Now you got it. I tried multiple published projects that had quit working. All work again. :+1:

Thank you


#31

Really? Mine was updated on April 11th or something like that
But then again, my draft worked, and it probably had one of these loops

Edit: Weird, now it just got updated