My Drafts aren't loading


#41

#42

Is that what you have coded so far?


#43

K should I log out now? Yeh that’s all I wanted saved


#44

Try it. Another option is to go farther and delete and reinstall the app. I wish I knew what was going on though, this type of bug is so hard to fix! Everything works fine on my ipad


#45

Nope it’s still not working! Maybe I’ll have to wait till tomorrow when I could try on a different wifi to see if that makes a difference.


#46

The other drafts stayed saved though so that’s good


#47

It seems like there are two problems: 1. You are opening a project that is downloaded and it stays on the white screen with a spinner.
2. You try to download a project and get the purple loading screen without ever finishing downloading.

2 might be solved by different internet, not sure about 1. Are you still seeing both these issues?


#48

What do you mean by downloaded? And what does the purple screen look like?


#49

Purple screen is the loading bear.

When your project is on the Hopscotch server but not your device (ie anything in the community) you see the loading bear while it downloads. If you never get past that screen it’s likely an internet connection problem either on your end or ours.

When your project is on your iPad you won’t see the loading bear and will go directly to the editor or the player. If you end up on the play screen and it is stuck at white with a spinner that’s probably a problem with the project code that you wrote or the code for playing the project that we wrote. Or some bad combination of the two.


#50

uh hehe cuz I don’t use my drafts that often

hehe sorry dood


#51

Ok yeh I’m still having those issues. And the code I first wrote that started the glitch was for pixel arts that would (theoretically) load faster by setting its position to draw the pixels instead of moving in the direction it needed to go. I never got to test it though because of the glitch. :thinking: Probably doesn’t help that much but idk.

I’ll just put out my course of events in case that helps
-I made a new draft
-wrote the code
-hit play and found it didn’t work
-tried leaving and going back in to load it
-powered off my iPad and turned it back on to access hopscotch
-discovered that my other drafts didn’t work
-made this topic
-tried the advice people gave me here and then I found that other peoples projects didn’t work either
The end!


#52

Honestly, I would delete and redownload the app. It sounds like something really weird is going on that I don’t think will be fixed with WiFi or time.


#53

Ok well thanks for your time and thanks for the awesome app :clap:t3:


#54

Gasp* it worked! Thanks!


#55

I am using a school iPad and I can’t delete apps…what do I do?
@awesomeonion


#56

You are having the same issue as my_pizza?
Can’t open drafts or can’t download them? Which version of Hopscotch?


#57

What’s your username?


#58

My username is OfficialHopscotchRemixer and I am using version 3.24.2.


#59

And can you describe exactly which bugs you are experiencing? Drafts vs community projects etc. plus screenshots please!


#60

Well the same exact problems that MyPi was having. As forcscreenshots it is just the bear loading screen and the drafts loading screen. I think you know what they look like but I can show you if you really need them.