Menu disappearing immediately after opening? SOLVED


#1

I’m making a project that has a menu that’s supposed to open when you tap an arrow, and close when you tap the arrow too.
Except it’s immediately closing after opening.

[details= screenshots of the arrows code]
There’s two arrows (one for opening, one for closing) because using one arrow didn’t work (but the code [or similar code] worked in another project and it doesn’t really make sense to me that it’d work in one project but not another).

(It’s in the last scene)


#2

I am not on my iPad right now, but maybe the arrows are lying on top of each other, making the tap event trigger for both objects when you tap them?


#3

Could you post the menu’s code?

It could possibly be a timing issue. Maybe try for the first arrow:
when self is tapped
Wait 10 milliseconds
Set :iphone:menu to 1

I think that it is definitely possible to do it with one object. I’ll try that later.


#4

Can you show me where the bug is in editor


#5

The code pictures?
They’re on the first post.


#6

I will look


#7

I got it to work!!!


The thing that happened was the clear button was setting Menu to 0


#8

Oh
I forgot to unrig the project for testing
Thanks!


#9

Ur welcome


#10

Hurry too, tomorrow is Hopscotch’s birthday!!!


#11

Yeah, I can’t wait!


#12

I wonder if there will be an update


#13

Maybe… you never know…