Making a draft from the create button produces womp error

Use this template to make awesome bug reports:

Your username:
mr. incognito
What kind of device are you using?:
iPad 5th gen
1 sentence description of the problem (I was doing _________, and then __________ happened):
I made a new draft (from the create button) and put 1 rule with 1 block (set size) in a Sprite. when I played the project a womp error appeared. it’s done this every time I’ve tried, which is about 10 times
Steps that the Hopscotch team can take to reproduce my problem every time:

  1. make a new draft from the create button
  2. add some code
  3. play the project

I expected this to happen:
no womp error
But instead this happened:
womp error
Here’s a sweet screenshot:
not really much to screenshot, i had the following code:

when game starts {
  set size percent 110
}

it’s only when you have never exited the draft before. if you exit it then enter it again, it works fine

  • I have this bug
  • I don’t

0 voters

12 Likes

i don’t have this bug lol

3 Likes

what version of hopscotch are you on?

4 Likes

the newest i think

3 Likes

I tested this out, and this bug doesn’t happen for me.
An easy way to avoid it is to create a project from drafts instead, but this still needs to be fixed.

4 Likes

I don’t have this but I didn’t update my hopscotch yet.

3 Likes

so it’s just me who has the bug…odd, I wonder why it happens to me

how do I create a draft without pressing the “create” button? all I can think of is duplicating a draft

3 Likes

:joy:
omg lol

2 Likes

It happens to me every time. This can be fixed by going out of your draft and back in. That’s what I had to do every time I make one. It even womps when there is no code in your freshly created draft…

Device used: iPad Pro 11” 2018, iPadOS 14.4, HS version 3.46.4

Literally, create a new draft and immediately play the project. It STILL womps…

Glad to know I’m not the only one…

3 Likes

I thought you meant the ‘create’ button on your profile, my mistake.
This still doesn’t happen to me, though. Some strange device glitch, maybe?

3 Likes

I’m talking about the one on the bottom right of the screen (has a plus symbol), is that the one you thought I meant?

possibly

2 Likes

No, this button:
image

3 Likes

ah, I forgot about that button, my bad

I only see it when I search my username—it still happens when I make a draft from it though

2 Likes

So the problem here is that when you create a project (using either create button), you are given a womp message?
That makes more sense, but I still don’t understand why this only seems to be happening to you and Crosbyman (others to come).

2 Likes

yep, and it only happens when I first edit it—if I exit the project then enter again it’s fine

I’m also on iPadOS 14.4, so maybe it has something to do with that

2 Likes

i have also iPadOS 14.4.0
the only difference between us is that you use a iPad 5th gen and me a iPad 6th gen
not a big difference
but i don’t have the bug lol

2 Likes

Very weird indeed - I have to check if I have this!

3 Likes

It seems you’ll have to keep doing that until it’s fixed.
I don’t think the problem is iOS 14.4 because I have the same iOS version, and this currently isn’t happening to me.
Maybe something to do with your device version?

2 Likes

dosent do that to me
when i started working on a draft nothing happens
maybe its from the many big projects?

2 Likes

I don’t think so, this is an empty draft and I don’t have any large drafts currently

2 Likes