Lost progress on game


#1

Use this template to make awesome bug reports:

Your username: I'm using Jedi4Jesus for this project

What kind of device are you using?: Ipad Mini 1st generation , IOS 9.2.1

1 sentence description of the problem (I logged back into my account, and I lost about 20 minutes of work on one of my games):

Steps to make the problem happen:
1. It didn't say I needed to upload any drafts, so I logged out
2. I went to my AwesomeJediE account, published 2 projects, liked a lot of projects
3. I logged back into my Jedi4Jesus account
4. I downloaded my HHC2016 project to work on it
5. Some of my progress was saved from yesterday, but not all
….

I expected this to happen: All of my progress would be saved

But instead this happened: Only some was saved

Here’s a sweet screenshot:

These should be invisible, as well as "The Halloween Games" (I just forgot to highlight it :stuck_out_tongue:)

Missing code


Hopscotch team,
Should I continue working on the project, or wait to do anything in case you guys can fix it? Thanks!
Edit:

Ok, maybe I'll just start working on it anyway...I'll wait a few minutes in case if someone replies.


#2

This has happened to some other people as well. Some people have even lost the entire project, so you're lucky you only lost some code!

You should probably email THT!


EDIT: Nevermind, don't email them. They're already fixing it!


#3

It's only like 20 minutes of work thank goodness, I don't think it's drastic enough to email them... I'm just reporting another common bug so they can nail it down and squash it


#4

I've caught up to the work I'd lost, and made the code look a bit cleaner since I was doing it over again. I'm also making good progress on the game :smiley:


#5

This happened to me a few times too! Here is what I do:

After I finish some work on code, I exit out of the project. I duplicate the project and delete the original. This way, your work can't be lost! :D


Lost a lot of my projects after signing out!
#6

Last school year, I lost a whole game, I worked like 2 total hours on, and was sad, but.


#7

Great idea! I forgot about that feature xD


#8

;-;


#9

I finished the game by the way! I published it an hour or so ago.


#10

Can you send a link to the link to the project please?


#11

https://c.gethopscotch.com/p/yack72rgz , but it's fixed now. P.S. It still works in the webplayer, but it's a bit glitchy. Welcome to the Hopscotch Forum @AlexBro !


#12

It says the page doesn't exist when I clicked it... ;-;


#13

Fixed it....sometimes when I copy stuff I accidentally copy the number of clicks next to it as well