Lightrail Glitch


#1

Hey!

There have been some glitches with my game, Lightrail. Take a look:

It works perfectly fine on my iPad...

Did these glitches happen to you?

  • Yes

  • No

0voters


#2

It works just fine with me! That's weird that it's happening. I really like the game @Rawrbear


#3

Thanks! :smile:


#4

Yeah, once in a while, it would be making a complete wall of moons and asteroids.

And I'd be like

:scream: :scream: :scream: :scream: :scream: :scream: :scream: :scream: :scream: :scream: :scream:


#5

What iPad do you use, and how many apps do you have installed? Is your iPad slow? Can it handle lag?


#6

All this stuff, uh...
- Let's see, iPad? I'd say it's a bit old like one or two years (the iPad is in another room, but I'm too lazy to check :stuck_out_tongue_winking_eye:)
- Apps, non-default, I'd say about 20 others, most are ones I don't use anymore, so I use the same 5 or so.
- Speed, connection's great, but the lag on some huge projects just almost immediately freeze and then crash the app. (Lightrail didn't, so don't worry!)
- Lag is a main problem, but it's okay on my iPad. Laggy projects I've played are Helicopter Rescue, Sushi Simulator, or ones loading clones will lag, but not crash. Ones that everyone keeps complaining that crash the app, like Surgeon Simulator or the Car Game, will crash.


#7

Huh... I kind of want to know which iPad to use though so I can collect some info! I like investigating this stuff, I'm a geek! :sweat_smile:


#8

Alright, let me walk myself over to the room...
weird delay in typing
Oh wait, it's like only a few feet away. :sweat:
I'm directly quoting this from the bottom thing in emails you send to the Hopscotch Team.

Sent from Device iPad3,1,iOS Version 9.2, Hopscotch Version 2.17.1.1


#9

That iPad was made at iOS 7.1.2! That is kind of old... hmm... @Ian, can you use these stats to find a bug of some sort?


#10

This post was flagged by the community and is temporarily hidden.


#11

Is your iPad slow at all???


#12

This post was flagged by the community and is temporarily hidden.


#13

I have seen this same strange behavior on remixes of my stuff. Where I normally have a black background, I see remix notifications showing white backgrounds, but when I check-out the remixer's code, it's back to black.

Also, I've noticed that, when I publish a project and run the published version for the first time, lots of my graphics end up being HUGE. I have to restart Hopscotch on my iPad, in order to get it to go back to normal.

I'd call all of this a :bug:


#14

I haven't found this bug....


#15

":bug:" Off topic but that ain't a "true bug"!


#16

It works fine for me (I got 132), so I think they would just need to restart the app, and try again :wink:


#17

My friend got really far on it yesterday nothing happened to her or me. It wasnt in a big clump or specks


#18

I think (I'm not sure) you can do that if you go to the publish selection, and back to the project, it would display the so called "white screen". Not sure, but @BuildASnowman's remixes of my projects turn out like this.


#19

I am on iPad Air and your game is awesome!!


#20

Thanks for the info, here's a like! :heart:

So this happens to other projects...

@Huggingfluffybear, thanks!