Images not appearing (not uploading correctly?)

I searched this problem up but could find nothing so I made a new topic:

Use this template to make awesome bug reports:

Noland Games

What kind of device are you using?: (Also include iOS version, and Hopscotch version)

iPhone 6, iOS 12.5.5, hopscotch 3.48.3

1 sentence description of the problem (I was doing _________, and then __________ happened): I was making my custom art project, when suddenly the custom images started turning into the hopscotch logo

Steps that the Hopscotch team can take to reproduce my problem every time:

  1. Add a lot of custom images into a draft
  2. Play the project

I expected this to happen:

The project would play normally

But instead this happened:

The images turned into the hopscotch logo

Here’s a sweet screenshot:

Here is a screenshot and a video:

Has this ever happened to you?
  • Yes

  • No

0 voters

3 Likes

Sneak peak of my new game, ig :eyes:
If the video doesn’t work, then try this:

https://files.catbox.moe/sdixiq.MOV
1 Like

This happens if the images used are missing, or have been corrupted. This can be fixed by removing all images that are completely blank and re-uploading them.

4 Likes

This has happened to me, and it means Hopscotch could not find the image you wanted, so to fix: delete the images (Without the code) and re-upload them again

4 Likes

Well dang now that seems to work completely thank you very much!

3 Likes


houston, we got a problem

Another game that has this
I hope Hopscotch can fix this
@Crosbyman64

3 Likes

again, like we said, this is a hopscotch bug, not someone’s code bug

4 Likes

To be clear, EVERY custom image got corrupted, right? I think you’re the first one to notice.

2 Likes

I didn’t check much, but not EVERY IMAGE. The only ones that weren’t destroyed, were the level entry, where you pick a level

1 Like

Did any images survive in the editor scene?

I might be able to re-add the images, but it’ll take me a while.

2 Likes

Oh no, that can get really frustrating.

There is a bug report topic here Images not appearing (not uploading correctly?) but unfortunately it seems a bit tricky to investigate. (Need clear steps to make it happen every time)

Can I ask which project that is?

3 Likes

I don’t know about that one but the same thing was happening to my project farming simulator 2 when roadocean played it

Here’s a link to test if it works

2 Likes

From what I’ve seen. It occurs on any project with lots of custom images (usually over 50). Not everyone has this issue, so it’s very difficult to reproduce. It just happens by accident.

Project in picture:

3 Likes

@StarlightStudios @Crosbyman64 thanks a lot for the links & extra information

(Just moved the posts here to make it easier when I investigate)

2 Likes

Here are some extra



Yesterday, this was normal, but today isn’t? ^^^

2 Likes

Just wait until those normal looking tiles in the bottom image become corrupted like the other tiles.

It’s almost like the source to them is missing or unknown.

2 Likes

i still can’t get past level 4 lol

2 Likes

Yeah, the placeholder images make it impossible to know where the sticky walls are… or any other tile for that matter… Even if I re-add the images, the problem will eventually come right back…

2 Likes

Is anyone experiencing an issue where the images don’t load in correctly?

https://c.gethopscotch.com/p/12n7m8mmqn

I tried to play on my phone but only like half of the images load in.

4 Likes

thats a hopscotch bug and unfortunately we have no control over that
exit and reenter may fix the issue

3 Likes