How to make a scrolling limit on scrolling projects!

howtos

#1

Have you created a scrollable project? That's cool. But one problem, why can I just keep scrolling up and down without a limit? Today I can teach you how to put limits on all your scrollable projects! If you don't have a scrollable project yet, please make one before you continue.
Step 1: Create a new rule. Drag in the "When ___ is smaller than ___"


Step 2: In the first empty space, once you tap it and you are in the calculator, go to values. Then get to the iPad values and select the value Scroll. Select the second empty space, type 0.

Step 3: Drag out a Set Value block and set the value Scroll to 0.

Step 4: Now drag out a "When ___ is bigger than ___" block.

Step 5: In the first empty space, like Step 2, go to values and put in the value Scroll. In the second empty space, type in how many "positions" you want to scroll down. For example, how many Y positions you want to scroll down after 0 Y position. My standard use is 1000 Y positions past 0.

Step 6 THE FINAL STEP: Now bring in a Set Value block. For the value, put Scroll, and for the number, put the same number as your Y position.

And now you are finished! Sorry, this took me well over an hour to write it all.
Hope it helps!


#2

Thanks @t1_hopscotch for telling me how to do this a long time ago!


#3

Hi @WoodenSwan THIS IS SO GREAT!


#4

This is a really great tutorial! Great work :smiley:


#5

Thanks guys! If anyone else browses this topic, I'll explain what I did for setting the scrolling limits if you don understand.
For the first rule, When Scroll is smaller than 0, it sets the maximum height position to 0 Y position. So you can no longer scroll higher than that.
For the second rule, When Scroll is bigger than 100, it sets the maximum height position to 1000 BELOW 0 Y position. So you can no longer scroll lower than 1000 below 0 Y position.
Sorry if it sounds confusing, I tried to explain it as best as I can. :sweat_smile:


#6

Reviving because this may be the first one year later :smiley:


#7

Ummm, maybe update your editor?


#8

I made like 6 one year later bumps lol