How to determine if iPad has been swiped?



I tried that but it has no iPad option.


I probably need something using values.


Well, that's easy. If it's missing and hasn't been misplaced, then... yep, your iPad has been swiped!

J/K :blush:

I dunno.


You can have a 99% invisible object. Then add a rule to it so it is so large it takes up the entire screen. Then you can use that as the thing you swipe!


Wait..there IS a choice for iPad in ________is swiped (left, right, up, down)!


@NDSDNS There is a way to secretly hack it in, which is what @CreativeCoder found :wink:

All you have to do is drag a "When ___ is tapped" (or any other When that has iPad as an option)

Then drag out that When to delete it. And then just drag in any "When __ is swiped" and you'll see iPad as an option! :smiley:

It's probably a bug because you can do things like "When iPad bumps iPad" as well, and the Hopscotch Team knows about it since I told them. But I'm glad it's still there so we can do things like these :smile:

@t1_hopscotch how'd you get iPad is swiped?
When iPad is swiped
iPad is Swiped Method!

@t1_hopscotch Yeah, that makes sense. I didn't even know what I was doing :smile:! When iPad bumps iPad sounds like some feature on a new Apple device! That's strange, though. It's kind of like how you can put a value block in a Leave a Trail.


Thanks @t1_hopscotch. You have always been on my list of most advanced programmers :wink:


@NDSDNS I tried the iPad is swiped trick @t1_hopscotch said with the using a "is tapped" block, and it worked. The project showing this is here:

this is the link to that project


Thanks @CreativeCoder!


No problem @NDSDNS! I hope your project turns out well :wink:


@NDSDNS maybe try following the instructions one more time? :hushed: I'm not sure why the "hack" is not working.

(And I'm continuing the discussion here so that we don't fill a different topic with posts that aren't related to the discussion :wink:)

Update: okay I see it's fixed. Thanks @CreativeCoder for helping out :smiley:


I redid it and it seemed to work (hopefully)

Good idea linking this to this post


@t1_hopscotch there is no iPad is pressed or iPad is tapped or anything. The first time though I tried using bumps and the hack worked because it got edge of screen and anything but I can't get iPad. However, as @CreativeCoder showed me, if you leave the object to swipe field blank then it's the same thing :grinning: .


@t1_hopscotch the ipad is swiped hack is not working. :cold_sweat:

How to determine if iPad has been swiped?

What part uses that? I can check it out if you want


OK I sent it to you.


I made it so when the iPad is swiped up the menu comes up. I hope that's what you meant


Thanks @CreativeCoder!


2 posts were merged into an existing topic: Working together w/ NDSDNS