Hopscotch keeps crashing within 2-5 minutes of opening app

yes
that was the test project

1 Like

I opened an object with 2+ rules and scrolled down (left side of screen)

I closed the object then immediately opened the object with 1 rule (right side of screen)

It didn’t crash for me.

What version are you running (HS version)?

I noticed you had something else opened in the background (right side of your screen with the arrow pointing left). (App in slideover / Picture in Picture)

Location of objects on screen

230, 562 first object

890, 456 second object

how did you tap it? i said to be careful with this part

1 Like

I tried both ways:


Test 1: Via double tapping the object (for both objects)


Test 2: Via tapping the object and tapping “See Code” (also for both objects)


Neither made the app crash for me.

Does the issue you are having also occur on version 3.48.0? I noticed the video was recorded prior to the 3.48.0 update.

This crashes on 3.48.0 all but one of the times I’ve tried it.

This does not seem to happen at all if the rules in the first object do not cover more than an entire screen (so you have to scroll to see the whole thing)


this doesn’t cause a crash.

It also doesn’t seem to happen if you have just created the draft and never exited it. I’m not able to reproduce it in the second draft I made.

The first one also no longer crashed, though I did change the code a bit to see if it needed to scroll off screen.

I’ll email you the crash reports from this.


I’m not sure if this is the same bug but on my phone while coding every once in a while the app would crash when, after closing one object’s code and opening another’s, I would either add a new when block or tapping the inside of an existing rule to add a new block.

4 Likes

Interesting - and yes please send me the crash reports!

4 Likes

What device are you using?

1 Like

I just sent you the analytics for the crash report via email.

2 Likes

The crash will happen on all devices that follow the steps to reproduce, but their device looks most likely like a M1 compatible Mac/MacBook.

1 Like

For future reference: The new Macbook will crash Hopscotch - a known bug is when you log into a new account it will immediately crash. We’ve contacted Apple about this as it might have something to do with their end.

In this topic, I’d like to concentrate on iPad/iPhone crashing issues, so please send me any steps leading up to the crash and a crash report if possible!

4 Likes

thanks a lot @Petrichor, this is exactly what i found but i have a great difficulty to explain it because my english is limited

@Crosbyman64 refer to Petrichor’s post instead of mine

Yeah, it totally crashed (tested twice)

Also, it seems you can save yourself from a crash by opening the same object without scrolling and closing it again, then opening the other object afterwards. Note: this might still make it crash for you

1 Like

yes ik (it doesn’t crash and it’s normal)
tbh i tested everything in every scenario before i tag yuanyuan

1 Like

see post i’m replying to

1 Like

I am now getting constant and consistent crashes with the app, and I’m very certain the analytics data doesn’t like me anymore.

It now crashes within 20 seconds, and I’m very certain it’s only gonna get worse from here. I am literally no longer able to make even the smallest change on my game STAR-LINK. The only way I would be able to is my updating it as a draft, but I know that in itself is forbidden under any circumstances due to the seed based features it has.

I am also very certain that reinstalling the app won’t fix anything this time.

1 Like

Have you tried logging out and logging back in? It removes all the cached images (THID DOES IT SAFELY, DONT TRY AND DELETE THEM IT WILL MESS YOUR PROJECT UP)
Also try updating your iOS to the latest version
Another good idea is to free up some space on iCloud and on your iPad.
If this helps just notify me and or Yuanyuan.

  1. I’m only using 934 MB of 5 GB of iCloud Storage
  2. I’m on the latest iPadOS version
  3. Usually I have to uninstall and reinstall Hopscotch to temporarily fix the crashing issue. The only issue is all progress in projects including seed purchases are lost forever.

Also, I have manually deleted images (that weren’t mine) before and I haven’t run into issues with images being corrupted.

1 Like

I’m pretty sure that seed purchases aren’t cleared but your project does keep clearing my save data.
Which iPad are you using?
Have you jailbroken the iPad or modified it in any sort of way?

1 Like

Apple iPad Pro 11" Gen 1 (2018)

It cannot be jailbroken for all I know.


Also, did you tap “New Game” or “Load Game” in my game? I have had issues with some features not loading correctly, but I have fixed those recently.

2 Likes