Hopscotch Doesn’t Load?

Use this template to make awesome bug reports:

Your username: Short Circuit

What kind of device are you using?: According to settings, a 5th generation iPad.

1 sentence description of the problem (I was doing _________, and then __________ happened): I was trying to load hopscotch in my school iPad, and then I successfully logged in, only for my number of seeds, plants, and username to load, but nothing else (including drafts, published projects, notification, and playing games tab.) I have tried on both school and home wifi and it still doesn’t work, and have even tried deleting and redos loading the app. It works fine on my phone and personal iPad tho.

Steps that the Hopscotch team can take to reproduce my problem every time:

  1. Open Hopscotch on this iPad
  2. Make sure you’re logged in
  3. Nothing rally loads

I expected this to happen: I would be able to work on/see my projects and see/play other projects, but they can’t load or connect.

But instead this happened: Basically nothing loaded except for my username, seeds, and plants.

Here’s a sweet screenshot:




9 Likes

I’ve had this happen

5 Likes

Did you find a solution when it happened?

5 Likes

I restart my router most of the time and it works

'tis annoying cause drafts are supposed to be available offline

5 Likes

That’s weird. Mine doesn’t work no matter what wifi I’m on, and all my other devices work so I don’t think it’s the wifi

5 Likes

When this happens to me I just swap WiFi then swap back and it gets fixed most of the time. If it doesn’t get fixed then I just wait a hour or two then open it and it is fixed.

5 Likes

It looks like this could be a temporary internet issue, which most likely is related to your home network or you internet service provider (the company that your household buys the internet connection services from). If this doesn’t resolve in a few hours, try restarting your iPad. Then (as others said), try restarting your router. If that doesn’t solve the issue, check if your iPad or network has some kind of connection restriction or management. You can ask your parents if you have a time-triggered internet access filter, for example. And if it’s a school iPad, you can ask your school for more help.

6 Likes

Okay okay thanks

It’s been happening for a week or 2 now, first of all.

I’ve tried restarting my iPad, deleting and renown loading the app, and have tried on multiple wifis, both home and school.

I can try reaching out to the school, but knowing them, they’d just try to give me a new iPad which I’m not willing to do.

7 Likes

When I was in 7th grade, I had this exact same problem with my school iPad.

Reach out to a friend and check if they can also use hopscotch on a school iPad. Otherwise, the school might have done something.

6 Likes

Understandable. You can give the school a link to this article, which might be helpful for them!

5 Likes

Is this a school ipad or school network? Are you able to load your community if you switch to a different device?

6 Likes

@DaughterOfHecate @Ren

Could you both send me a screenshot of the About Page? I will file a report for this issue, but it sounds like it might be a temporary glitch. If you switch into another account, does it happen for every account? I can reproduce the issue when I log into accounts that receive a lot of notifications.

7 Likes

It’s not happening right now but it has happened before

4 Likes

Here’s the about page. I tried logging onto another account, and yes, the same thing still happens

7 Likes

Unethical tip: whack your modem, it’ll start working /s

7 Likes

this happened to me I just shut down my IPad for a day or for few mins and it start working again

6 Likes

This has happened to me a couple of time too, switching off WiFi in Settings then switching it on or moving closer to the router usually works for me

6 Likes

This has been happening to me since mid-August. Very annoying, and I’m still not sure how to fix it.

2 Likes