Help test my game! (bugs and lag help!)


#1

So today there was an update to Hopscotch which made all my projects run faster. This is normally good, but the project that I was about to publish is now running at twice the speed. I tried slowing it down by changing the variables but that just caused more problems and bugs. Any ideas of what to do??

EDIT: @Petrichor and anyone else would you mind testing my game? Let me know if it is laggy at all because sometime after you hook the fish it gets laggy for a second. For some reason when I play It through the link it is super slow but when I play it as my draft it is normal speed.
https://community.gethopscotch.com/projects/zn3kjtzst
https://community.gethopscotch.com/projects/zlaw9bjmh#


#2

Why is it running faster a bad thing?

If you’re using waits, try changing them to waits that last a specific amount of frames.


#4

It’s a game with objects that move across the screen, and they move using set position blocks. The problem with the project running faster is that it lags (moves 5 forward, stops for a split second, and then moves 5 more) instead of one fluid movement. I’ll post a screen recording of the project later.


#5

Okay. That’s odd. So it’s like

Set position (self x position + 5, self y position)?


#6

Yes exactly, which for some reason makes them move weirdly.


#7

I’ll test some stuff, give me a second.


#8

Also, are they in draw a trail blocks?


#9

Thanks, and no it’s just in a repeat loop.


#10

The problem also might be that the project has a lot of clones. (Not a huge amount but maybe around 500)


#11

I’m seeing it too on a new project with just a sloth

I may have fixed it by having two rules of move forward 2.5, but it may not be fixed.

Sometimes it looks like it stops for a bit but I think it’s just changing y with my finger.

I’ll remove the last’s touch y actually


#12

Okay I don’t think I’m seeing it.


#13

Now that I’m looking at my project again it isn’t doing it as much, every once in a while they glitch and do it but not often. Now there seems to be more of an issue with the project lagging at certain times. I’ll send a screen recording of it


#14

Wait, now it’s not lagging at all and I didn’t even change anything. Weird.


#15

I didn’t encounter any lag.

I was only able to do free play mode though because I have my Hopscotch in a differential font (courier) so the start button was blocked, but it was pretty fun.

I like it.


#16

Ok great! Was it running slow though? It was slow for me. I think the new update didn’t work on the link.


#17

No. It was fine, why?

I think. It didn’t seem slow to me.


#18

Ok. Were the fish from the beginning screen still sticking out during the game like this: (that’s what happened to me when I used the link)


#19

Yes.


#20

Hmm, try this one:
https://community.gethopscotch.com/projects/zlaw9bjmh#


#21

That works.