HELP! Bug in Hopscotch: The editor crashes!

#HELP!
I can’t publish anything in Hopscotch,my editor is crashing all time!
@Liza, @Meg ,@Rodrigo ,@Montoya, can you please fix it or tell me what to do? I am vey sad because I can’t publish anything if it keeps crashing like that!

-@LunaMorgana387

#Bug report:

Your username: LunaMorgana387 :crescent_moon:

What kind of device are you using?: iPad Pro with Hopscotch updated to the latest update available.

1 sentence description of the problem: I was doing a project, and when I tapped the play button,it appeared a loading icon instead of the project and when it stopped loading,it crashed.

Steps to make the problem happen:

  1. Do a new project
  2. Do some code and add some characters and text
  3. Tap the play button.

I expected this to happen: That it would load immediately rather than seeing the loading icon and crashing.

But instead this happened: It appeared the loading icon and it crashed.

Here’s a sweet screenshot:

Then,it crashed.

7 Likes

aww, this happens to me, but just sometimes...
Idk how to help.

3 Likes

I am very sad.Please,I hope that @Liza,@Meg,@Rodrigo or @Montoya fix this bug ASAP or ar least that they see this topic!

3 Likes

Ya I already made a topic like this, did you get the new update?

2 Likes

I have the latest update,but since the cloning update was there,the editor got slow and laggy,and it's still crashing. I am dissapointed. :disappointed:

This happens to me too! If it happens often, email the Hopscotch team and they'll be sure to help you.

2 Likes

OH no! We're so sorry for the delayed response here.

Have you tried deleting and reinstalling the app? I know it's lame advice but it can work.

Let us know! We'll watch this thread for your reply.

3 Likes

I tried, but is still slow and now, when I try to remix something and I rename it and publish it, it says "Opps! You need to type a name first." and I typed another name for the project, but it says the same. Can you (or other moderators) fix it? Thanks for the reply!

This is the only project I could publish @Liza: