Gripes (Bugs) about the New Update [Solved]

# The auto-versioning (it turns out, this was not the issue)

Use this template to make awesome bug reports:

Your username: Awesome_E

What kind of device are you using?: iPad made of oxygen 2 (iPad Air 2)

1 sentence description of the problem: I updated and took the word for the change log, some of my drafts broke.

Steps that the Hopscotch team can take to reproduce my problem every time:

  1. Have a draft at webplayer 29
  2. Update the app

I expected this to happen: They would stay at 29, like the changelog states

But instead this happened: Anything with Webplayer 26 or higher automatically changes to 30 when it is opened

Here’s a sweet screenshot: No, I have better proofs.

Saving an Project with player version 29
  1. JSON File of the Existing Project
  2. Saving as Draft
  3. Before even opening the draft, here’s the JSON file. It will always change to 30 every time you save or edit a project if it is at 26 or higher.

Basic projects like that one, nothing happened (at least when saved).

The Issue

  1. Existing Drafts get converted to 30. Allow me to show you what happened:


The existing draft no longer works. It freezes right after I play it.
I show the keypad’s code to prove that the work was not just incomplete.

This project had some logic, if loops and variables, but no secret blocks

What else could possibly go wrong? I made a copy of E-Pad and that wouldn’t run either.

I believe this issue will only freeze the project if it was a draft.

That’s why it’s a bug. I feel a bit ripped off with this update. I can’t edit E-Pad until there is a fix, because if I try, Hopscotch will rewrite the version and prevent the project from working.

Since published projects are on frozen in time, those still work. But once you save it, it converts. You might be able to play those, but for drafts, nothin’ worked for me.

Projects will rewrite the version when saved or entered
This only occurs when the version is already 26-29.

The above statements have been proven false. It is not the webplayer version listed in the JSON file and has nothing to do with drafts. It’s just a flaw in the newly written webplayer.

# Editor button Placement (see note at bottom as well)
  1. “exiting instead” Who said that? I have never heard that before
  2. “Where you expect them” We are all used to play being in the same spot as edit, and publish in Hopscotch was never on the right side. Who thought that was a good idea? I’be already hit publish instead of edit 3 times today. Also, now it’s just inconsistent with published projects (edit is still on the right)
  3. If I want to exit a draft after testing it (but not adding more code), I can use the home icon button. Now that’s gone.
  4. Also, now we can’t have thumbnails anymore. This has happened in the past, and I do remember it. There was controversy and it was later updated to be able to use thumbnails in drafts again.

Forget my complaints, except one: Just add the home button back somewhere in the draft player so that we can have a more organized drafts page.

# Conclusion (once again, note at bottom)

Overall, this update doesn’t have the best impression on me, to say the least. I nearly lost E-Pad (remake draft) to this update, and many people working on large pixel arts could suffer. More confusion and inconsistency was added to the UI, and we can’t see new works by people we’ve never seen before (newest, but that is not the point).

  1. Stop auto-versioning drafts. This seems like intentional behavior, as this was never coded for and doesn’t seem like just a bug, but I’ll refer to it as a bug. It causes huge code loss
  2. UI Layout – who asked for that? I prefer thumbnails even if it means “accidentally exiting the project” 1 time every 3 weeks.
  3. The already reported bug – see code buttons on new shapes (no white space) are too close.
  • This is super risky, I think the update should be pulled / revoked.

I’m warning you: Don’t update – you could lose your draft that you spent 30 hours on. I almost did, and I don’t want that to happen to you guys.

I made a webplayer fix for the update, topic is somewhere here: WEBPLAYER FIX – Bricked by the Update? Fear no more! [OFFICIAL] – it turns out that the update was completely fine, except for one thing: the feature where objects adapt the new object’s width and height.

  • I fixed the issue by removing the code where the objects adapt, and everything works again. And I reverted the pixi but I don’t know what that actually did.
  • To my surprise, objects now adapt width and height properly. And the bug with it was gone!

# The Solution to the Issue is Posted Below

So, it seems that we have two options:

  1. Just push out a webplayer update. This will ensure that every user gets the fix (obviously it doesn’t have to be mine, but as long as it works).
  2. Push an app update as well as do the above, adding a home button to the UI of the playing a draft screen

Don’t think about taking first reply

  • Your points are valid, although I have not had this issue myself
  • Your points are valid, and I have experienced this
  • Thanks for warning me, I had no idea!
  • You warned me too late
  • I assumed that your points are not valid, and I updated and it happened
  • Your points were not valid and it did not happen for me

0 voters

  • This update causes too many issues, remove?
  • This update is perfectly fine, keep it around

0 voters

Please respond with iOS version and device

I’m on iOS 11.3.1


Nope, never happening, and i’m glad that I does not for me first non-creator reply


I think these are good points and something should be done about this. However, I think that things like the new shapes and ‘Set width and height’ blocks making more sense are good things.

I also hate how the buttons have moved… :angry:


Yeah I don’t like the new button placement

1 Like

I think this only effects people with a older editor version and older webplayer version

1 Like

I’ve only opened like 2 projects with the update so far and those have been okay but I’m not sure how it’d affect the other drafts I have…
But, if someone creates a project originally with the update, and it gets pulled, wouldn’t that project not work anymore?


I never opened any project (by other people)because it takes forever to load. Does this have something to do with the update or is it just my problem?

Very detailed and well-explained. I haven´t updated the app to the latest version myself, but I hope that THT will take a look into this!

1 Like

Is this the first time an update has a problem?

1 Like

Shapes and multi touch are good, but I don’t get those in my old drafts anyways. Rip E-Pad


@TheOnionSWE @Legendary_myth @MISSION_IMPOSSIBLE @GameCodingCrazy123 @TheCMStudios @FearlessPhoenix @William04GamerA @Rodrik834

Voters in poll 1:

Could you please provide:

  1. Your iOS version.
  2. If you use my shortcut, can you find the webplayer version trait? Is it 29 or 30 for existing drafts made before the update?

This bug has happened for every draft I tested so far. It runs about 6 frames, then freezes


I haven´t updated yet… makes me question myself why I voted in the poll. I´m very excited about the changes and updates, and I have my iPad with the old Hopscotch app on it as a backup, so I will probably update to the latest version on my newer iPad and let you know what happens! I probably have to wait a couple hours though since my brother is using it right now.


iOS 12.4 beta 3

1 Like

I have experienced random conditions being forgotten though

1 Like

I was, but now I regret updating. Plus the editor buttons are not. “Where I expect them”


Changes happen and may take some time to get used to. Remember the jump to the “new” editor? @awesomeonion said herself that the new button placement is made to be less confusing for new users.


But is it? All it does is make it inconsistent between drafts and published, plus, we need thumbnails. And it drives long-time coders crazy. It’s happened before too, and it was reverted because of the same reasons


I understand. But I´m sure that THT must have done some research about it.

1 Like

Just like last time?