Duplicating projects do not work when project isn't uploaded to cloud

Use this template to make awesome bug reports:

Your username: Cutelittlekittycat

What kind of device are you using?: ipad

1 sentence description of the problem (I was doing _________, and then __________ happened): I was duplicating a project and then it did not work

Steps that the Hopscotch team can take to reproduce my problem every time:

  1. Duplicate a project that’s not uploaded in the cloud

….

I expected this to happen: the project to get duplicated

But instead this happened: it did, but then when I opened it it was blank and when I exit the duplicate was gone

Here’s a sweet screenshot: not sure how I can screenshot this…

5 Likes

This mainly happens due to a download error.

If your project is large, you have to wait for a few seconds to ensure it loads all the way before opening it. It won’t work 100% though.

5 Likes

I think this issue can also happen when you unpublish a project and tap it to quickly.

3 Likes

This also seems to happen if you save a project to your profile. A workaround is to make a copy of the project you saved, and that seems to get all the objects in.

2 Likes

Wait it worked for me now…

This happens sometimes and sometimes not

1 Like

this happens when you duplicate a project which is not fully uploaded on Hopscotch’s cloud.

3 Likes

Looks like the topic has been solved, but I am going to let it stay open for now since this (in my opinion) sounds like expected behavior, but it could be made clearer in the Hopscotch app that the project is still syncing, and The Hopscotch Team might want to look into that.

5 Likes