Draw pad not working?


#1

https://c.gethopscotch.com/p/xxz41giu6
I'm making a new drawing pad and for some reason, whenever I draw on it, instead of smooth lines, it draws DOTS. DOTS.
Can someone help me fix the code? Credit will be given!


#2

I don't see dots. Could you include a screenshot?


#3

You need to click on the first color for it to work. I haven't added any other colors yet.


#4

@Lightningstrike


SOMEONE HALP


#5

Fixed it. On a drawing pad, you shouldn't have the iPad is pressed rule on the drawing character. :wink:

https://c.gethopscotch.com/p/xxz4y3qzs


#6

Oh um where should it be then? @tankt2016?


#7

On the character that draws? That can't have an iPad is pressed rule, or it won't work!


#8

But where does the iPad is pressed rule go?


#9

On any object in the code? Only for drawing (not art pads or drawing pads), you need the rule. Unless you're using it in a game.


#10

Where did you out the iPad is pressed rule? I don't get it.


#11

I took out the iPad is pressed rule on the +, the character that draws. You're not supposed to have iPad is pressed there if you're doing a drawing pad.


#12

Then on the original version I tried what you did and why did I take it out and it didn't work?


#13

Maybe the width was on 0 or you made a mistake and instead took out iPad is tapped.


#14

Nope I did iPad is pressed.


#15

Do you want me to give you credit in the project?


#16

Of course! You should always give someone who helped with the project credit!


#17

I just wanted your permission first.