Draw a trail with set position does not work as first block in game starts

When you have a set position block in a draw a trail block as the first block of a when game starts rule, and any movement block after that (Maybe more. I thought it was any block but flip still lets it draw)
Here is an example of code that doesn’t work:


Result
This is annoying for lots of trail arts and means that you need to have an extra block, either any block that takes a frame (Set trail width/color and set variable do not work) before the trail is drawn, or the set position moved outside of the trail and a move forward put inside of it.

17 Likes

First reply

Did the entire screen go white or was your object already an empty text box? Now about the trail not appearing, that’s probably part of the white screen bug that is very common.

6 Likes

The trail not appearing is not at all related to that, no.

6 Likes

It might be. Try adding more objects (that can be seen in the player mode) and tell me if anything has changed.

3 Likes

Test it yourself, Petrichor is correct.

This happens when the canvas background is drawn on the first frame; it overrides all trails drawn on the first frame of a scene or the project

5 Likes

Well, he’s the one with the bug, not me!

2 Likes

Then don’t make up an explanation just to post something.

4 Likes
2 Likes

And I can confirm this as well. This is a bug, I was going to make a report a while ago.

2 Likes

Yeah it happens to me all the time since forever ago.

I have noticed this and was planning to make a topic, but never got around to it.

1 Like

Thanks for finally making this topic! It’s been confusing me.

1 Like

Thanks for reporting, we’re taking a look.

6 Likes