"Done"-button does not work on old projects

Use this template to make awesome bug reports:

Your username: William04GamerA

What kind of device are you using?: An iPad Air 2 with iOS 10

1 sentence description of the problem (I was doing _________, and then __________ happened): I was going to publish a project with an old player version, but nothing happened when I pressed the “Done” button.

Steps that the Hopscotch team can take to reproduce my problem every time:

  1. Make a project on editor version <= 24 or change the version of an existing project to that number

  2. Play it and try to press the “Done” button to go to the “Publish” view.

  3. Nothing will happen, despite if you restart the app or exit out/go back in again.

….

I expected this to happen:
The “publish menu” where you resize the thumbnail of the project and pick the name to appear.
But instead this happened:
Nothing. No sound or visual reaction from the button and no menu.
Here’s a sweet screenshot:
Well, here is where I am stuck at:


I can not tap the “Done”-button, nothing happens…
@AwesomeOnion
16 Likes

Good bug catch :slight_smile:

7 Likes

But I saw it was published I guess…

4 Likes

What? Does the project appear for you?

5 Likes

Noted! What a strange bug…

8 Likes

Yes, it is. Perhaps you changed some line somewhere that needs an extra look at? :slight_smile:

5 Likes

Ugh. I hope this is fixed. AMAZING LOGO THOUGH!

3 Likes

Whoa this is a major bug!

I hope that THT will fix this thing soon!

5 Likes

It might have to do with the fact that project version 24- does not use the webplayer, but don’t quote me on that.

4 Likes

Yep, but when I checked it again, it was gone.

4 Likes

Thank you so much. I´m glad you like it!

2 Likes

This will be fixed in the next update.

9 Likes

Thank you so much, that is awesome!

6 Likes

Closed. This bug has been fixed.