Disappearing Objects


#1

Use this template to make awesome bug reports:

Your username: Jedi4Jesus

What kind of device are you using?: iPad Mini First Generation

1 sentence description of the problem: I was coding a piano using the “rule” feature, and at first it followed the rules, but now the objects don’t show up on screen.

Steps to make the problem happen:

  1. Code project, leave for a bit, come back.
  2. Delete a ton of old drafts (not sure if related)
  3. Come back, code still is still there but not working, and doesn’t show up.
    ….

I expected this to happen: Code would work

But instead this happened: Objects didn’t appear

Here’s a sweet screenshot:
Photo of code for keys:


Photo of what happens:


Shapes becoming invisible in player when visibility isn’t specified in code
Set Text causes "Whomp"
#2

I’m going to try publishing/unpublishing it…


Weird. It works when it is published but it doesn’t work when it is in drafts.


#3

Sounds like you’re experiencing this bug:

Your objects should reappear if you exit the draft and go back into it.


#4

It gets weirder
I tried to add some things to the draft to see if it would change anything. When it was in drafts, it showed the object (play button) at it’s normal size. I published it, and it appeared along with the piano keys. The piano keys weren’t showing in the draft but in the published version, as before. I unpublished it again and went to open it in drafts. Not only did the keys fail to appear, but the play button shrank! There is no code for the play button.



Note: I tried duplicating the draft and it came out the same.


#5

I’ll be putting in too much time to try solving this, although this was about 30 minutes of coding I put in. I’ll just start over for now.


#6

Something like this happened to me. Try leaving the project waiting, and going back on.


Hopscotch Bug Fixing / Reporting