Custom rules and abilities in old projects are broken

Use this template to make awesome bug reports:

Your username: Crosbyman64

What kind of device are you using?: iPad Pro 12.9" 5th Gen, iPadOS 15.3.1, Hopscotch version 3.49.0

1 sentence description of the problem (I was doing _________, and then __________ happened): I played an old project, and noticed every custom rule in the old player would not run

Steps that the Hopscotch team can take to reproduce my problem every time:

  1. Update to version 3.49.0
  2. Play any old project made before webplayer 2.0.0 (Point Towards (single equation) by ThinBuffaloSr is an example)

I expected this to happen: the code inside the custom rule/ability to run

But instead this happened: nothing happened

Here’s a sweet screenshot:

Confused? The hand is supposed to be point towards the star.

This breaks all projects that uses custom rules and abilities

5 Likes

any projects, including drafts

3 Likes

updating project to latest player does not fix it.
restarting device also doesn’t fix it.

The only way to resolve it in the current version is by redefining the rules and abilities from scratch.

3 Likes

I think I’m getting this too.

^ In 3.48.3, this waits a bit then spawns a bunch of podracers. In 3.49.0 it does not. I believe that all the code in this project is in custom rules.

3 Likes

This does work on the web version of projects. We’re investigating what went wrong (we did test for this case!)

4 Likes

This particular project is now fixed: Point Towards (single equation) by ThinBuffaloSr

2 Likes

Do you have custom rules nested in custom rules?

3 Likes

I do. In this project: Minesweeper_v2.6 by Crosbyman64 //it’s the one-object project

Perhaps you could fix this project too: https://c.gethopscotch.com/p/127eis9c8n (The Adventures Of Squaeyron v0.1.0.92 BETA) //I checked, and it doesn’t have any nested custom rules. Custom abilities, there might be some nested in them… this is the project I have more concern for, other than my seed project: STAR-LINK v0.1.91

1 Like

Everything should be working better now, though there still appear to be a couple of bugs to work out.

4 Likes

For me, it seems only the “point towards” project is working correctly so far…

2 Likes

will tht push an update to solve this bug for all projects (draft n published)?

For drafts you might have to publish and unpublish them to get things working properly, but we are working on fixing things for all projects.

The other projects are not fully fixed, but they do work better than they did before. It seems there are a few edge cases that people were using that we missed.

2 Likes

Well, the good news is the nested custom rules appear once again.

1 Like

Like a custom ability inside a custom rule?

Yeah at the moment there seems to be a bug with Whens in nested custom rules, from old projects, not being able to be triggered. If they are put in the outer custom rule, they can be triggered again. We’re investigating this.

2 Likes

Ok Whens in nested custom rules not triggering should be fixed now.

2 Likes

Should be fixed now.

1 Like

I checked, and everything works now. Should be safe to close the topic.

let me know if something persists and ill reopen this. glad its solved, thanks for a quick fix tht! :sparkles: