Copy and pasting text disabled

So, copy and paste just doesn’t work.


The buttons are greyed out, and selecting does nothing.
Anyone else have this? Know a fix? Thanks.

Hello at @Ana and @awesomeonion!
Sorry to summon you, but this may be a bug.
Basically no copy and pasting on iOS 13. A fix would be greatly appreciated. Thanks

14 Likes

I think this is happening to me as well? Don’t know how to fix it tho. Annoying…

3 Likes

Same, it’s been happening to me for a few months…

4 Likes

Your issue seems to be device dependent. On an iPhone 8 (iOS 12.4) & latest HS version (3.37.5) the copy/paste functionality works as expected. But on an iPhone, the GUI doesn’t have the icons. You have to ‘long press’ to get a pop up. If there’s data on the clipboard, the menu also gives Paste as an option.

Are you able to get anything with a 'long press"?

6 Likes

Not optimized for iOS 13 I believe

3 Likes

That’s an interesting catch. That’s probably it. I guess the cause of the problem is located.

2 Likes

And no, long presssing doesn’t produce any solutions.

1 Like

Yea it’s been doing that since the first betas

2 Likes

Well time to delete this topic then I guess. Yep?

3 Likes

Not sure, might be useful to keep it up if THT doesn’t know about this issue

3 Likes

Tagging time. Any suggestions on whom to bother?

2 Likes

Ana said to tag her for this stuff

So Ana and maybe awesomeonion

4 Likes

Aye. I shall edit that into the original post.

2 Likes

If I assess properly, This behavior is intended; copying blocks removes text from clipboard but not vice versa

3 Likes

That may indeed be a feature, I’m not sure, though complete demise of clipboard functionality isn’t exactly convenient.

3 Likes

I agree. But if it was intended, there is probably a good reason for it.

1 Like

not necesarily. it could have just been easier or the 1st thing that came to mind

2 Likes

Oh wait. After rereading that first post, it could be one of two things:

  1. iOS Keyboard bug. Sometimes you have to re-enter the field, app, etc. Just double check the consistency there.
  2. You’re correct, it is an HS bug.
2 Likes

Consistency is there. Everywhere.

3 Likes

We will take a look. Thanks for flagging @XAMANION

8 Likes