Code inside Block Glitch!


#1

Hey guys!

I was coding a really awesome game for you guys when I ran into a bit of a problem.
Normally, I would code my own backgrounds, but this game is a bit time-consuming to code, so I decided to just use a Draw Background block, which I have used before and works really well. However, I wanted blue as my background instead of any random color, so I clicked on the arrow thingy to edit it. However, only white was there, as you can see with the picture down below.

This is the first time this is happening!! I usually code on my iphone 7, which I HATE! I am looking to get Hopscotch on an iPad device soon!

Thanks for your help!

PEACE!

My Friends

@background_inc
@Xman0417
@PartTimeFemale
@ExistenceExistsToday
@William04GamerA
@yaygirls
@Paige1212
@Got_This_Glow
@eIameFemiTtraP
@DogWithAPen
@HopscotchRemixer


#2

Huh thats strange

U post the project yet?


#3

Not yet!
I decided to put that one on hold until I get a clear cut answer.

I am working on something else in the meantime!!!


#4

I think it’s an example for coders to use. It’s not supposed to code it, its wanting show an example of why you may use these blocks


#5

Maybe just reset the app, it’s probably just a small glitch.


#6

No, it typically has some code in there :confused:


#7

That’s strange! Hmm, maybe they took it out for newer players to expirament after the update? Or maybe it’s a glitch… you sure you never delete anything? Prob not
Hmm


#8

It usually has ode in it


#9

Thanks for the answers and concern!

I did not remove anything or do anything to the block!!!


#10

Maybe they got rid of that feature
I don’t know


#11

Does it appear on your other drafts/projects?


#12

did you delete anything like the custom “go to center” block?


#13

That is weird. Does it work in other projects?

Also, if you want to finish the project, here is the code inside that custom block:


#14

That looks like a custom rule, that is supposed to happen


#15

It is not a custom block, it is like one of those other blocks that sort of comes with hs’ newest update…

It’s hard to explain!
I’ll try it with some of my other drafts and let you guys know what happened!


#16

I have some new findings on this topic.

I tried it again, and it did not work. This is a different draft and object.
I also tried a different custom block. That worked. It seems to be only the “Draw Background” block that has that glitch!!


#17

The espresso machine has spoken:
This topic is approved

The espresso machine has advice:
Maybe use the form that shows up automatically.


#18

Try making an emoji huge. That makes the background the color of the emoji.


#19

I don’t get it. Nothing is wrong