Cloned objects get cloned in editor position

currently cloned objects are cloned in the x y of the object’s position in the editor. is this a bug or supposed to happen?

13 Likes

That took me a minute to understand lol. But wait what? Maybe send code?

6 Likes

I’m pretty sure it’s intentional since if it wasn’t don’t you think it’d’ve been fixed years ago?

10 Likes

To be honest, I don’t know. I think it’s a glitch. It’s actually happened to me once before.

5 Likes

nice vocab


@fundardo do you want me to post a link to explain easier?

5 Likes

Yeah that’d be nice.
lol I’ve never noticed this

4 Likes

I was experimenting with clones and music.

3 Likes
4 Likes

It clones just fine for me.

3 Likes

Ah, I see what you mean.

3 Likes

it’s supposed to clone. but notice how the clone isn’t made where monkey was at the time

4 Likes

The problem isn’t with the cloning, its with the position of the clone.

3 Likes

Uhh actually it’s never cloned at the position of the original object well idk about before 2016 but I presume that it’s been like that forever.
Your clone needs to have set position to original object position if you want it to go to where the original object was at the time of cloning

5 Likes

Yep, been like that forever.

6 Likes

I figure it should inherit the position though

2 Likes

It inherits the original object’s first position.

3 Likes

I think that the clone taking the exact position of where it was cloned would make more sense too.

4 Likes

that’s what I mean thank you

1 Like

But if you think about it, in real life, if you were to clone yourself, the clone would start off as as a baby that’s exactly like you when you were a baby, so the clone should start off exactly like the original object started
idk if that’s true actually that’s just what my dad told me when I was 4 and asked if I could clone myself to not do homework

4 Likes

It’s been this way forever, and if you don’t want the clone to appear on the screen in that position for a split second, drag the object off the screen in the editor. It’s’nt a bug.

2 Likes