Clone creation problem

I need help with some code. When a clone is created you can see a orange circle flash up on the screen. I find this really irritating to work with.
I know there is probably a simple solution but my brain really isn’t working today.

7 Likes

Let me upload a gif.

4 Likes

Tag CodeHelp?

3 Likes

CodeHelp

@CodeHelp

3 Likes

hm

send a link? i’ll see what i can do

3 Likes

A link would help, yeah

4 Likes

Well, I have this problem too sometimes, This doesn’t work in every case but you should make the first block in the clone’s “set invisibility 100” and when the clone is done loading, add a “set invisibility 0”.
If that doesn’t work then add an object the same colour as the background (if possible) and bring to front forever. and set invisibility 100 when the clones are done loading.

3 Likes

Always set clone Invis first before other code

3 Likes

And you should use a blank text as all your objects as well, so that they change properties when invisible. (Sorry out of edits)

Blank text

Invisible
Change prop
Visible

= 100% safe

3 Likes

Try putting a when object is cloned set invisibility to 100 immediately after whatever rule creates the clone.

2 Likes

I think I found a solution. I simply need to rearrange the order of the code so that when object is cloned set position self.x self.y. Otherwise it goes to the original position and then goes to the right position.

2 Likes

Is this still a problem or can it be closed?

1 Like

I need a link to the game then I should be able to figure it out pretty sure it’s easy fix:)

1 Like

Should this be clived? It seems unnecessary to keep it open.

4 Likes

yeah, probably
@Leaders please clive

1 Like

https://forum.gethopscotch.com/t/when-to-bump-a-topic/56130/36

1 Like

Yeah guys this was ages ago. I’ve sorta moved on from Hopscotch now and working on some Unity stuff. But yeah, I figured it out in the end. Can’t remember which game it was though.

1 Like

thank you! good to see you around, and hope your unity journey is fulfilling!