Can't place equation blocks on Set Color blocks


#1

I was trying to drag the plus equation block to the color slot in the Set Color block. After I tried putting it there, it just disappears! Same when I put equation blocks by dragging on other blocks. Is this a bug? How can I fix this? Thanks.

EDIT: Putting equation blocks on a block inside a Check if else block won't do the work. Well, I reported it to THT and hope it will be fixed soon.


#2

Try restarting Hopscotch, it seems to work for me.


#3

Make a value called Colour, and set that Colour to what ever equation block you want.


#4

When you are about to drop in the equation block, make sure there is no cloud bubble! Here, I'll show you.
When you drop it in make sure this cloud isn't there

It will drop in if the cloud bubble isn't there. For example:


To


#5

I've noticed this too, and have been trying to figure out when and why it happens. Could I see the blocks surrounding the Set Color block if there are any? It only happens to me when it's in some combination of Repeat Forever and Check If Else blocks.


#6

I'll try that. I tried doing it earlier even the cloud icon isn't there


#7

Also, if you used the second equation I used, the color will turn like this:


#8

Here you go:
The final Set Color block is the block I am trying to put the equation block.


#9

Okay, I'll go see if it happens to me when I use that code.

EDIT: Yes, it does. It also happens if I take the Check If Else blocks out of the Repeat Forever block or if the Set Color block's only in one Check If Else block. It seems like this bug is caused by having the Set Color block in a Check If Else block.


#10

I learned that if I do that on one rule too many times, it doesn't work...


#11

So, can I try putting an equation first before putting gin a Check if Else block?


#12

Yes, it seems to work if you do that.


#13

Thanks! 202020202020


#14

You're welcome! :slight_smile: