Cannot press triangle correctly (OPEN)

#1

Hey guys!
So, I was on an account, and I was trying to make an width customizer for an art pad.
The code looks like this

Which have always worked for the down arrow in the width variable.
When I try it, it doesn’t work, or it works for a short amount of time.

Do I try resetting something?

@Rodrigo
@Ana
@hopscotch-curators
@CodeHelp

Thanks!

10 Likes
Text (transparent background) masks other objects from touch events (OPEN)
#2

could you maybe publish the project so we can see the code for all the objects?
It’s prob a bug with your code or something

4 Likes
#3

Yeah sure!

1 Like
#4

Here @tankt2016

https://c.gethopscotch.com/p/1058z81mc4

1 Like
#5

It only works for me when I press the tip of the arrows.
Maybe it’s some bug with the hit box or something?

3 Likes
#6

Wait the tip?
Hmm lemme try
Edit- yeah true tho
Wait what do you mean hit box?

#7

I mean the area around the object that is the area that counts as tapped.
Like when the device is tapped inside the object’s hit box, the object will count as tapped.

1 Like
#8

Hmm good idea,
Let me try that!
Also thanks for helping :wink:

#9

Yep you’re right!
Thanks so much!

#10

The text is “covering” a majority of the arrows. Just delete this and it’ll work fine

4 Likes
#11

Oh, that makes sense.

1 Like
#12

Just fyi, the reason I put covering in quotes is that it’s not the part of the text that you see but the transparent part of the container (like a rectangular background to the text object) that’s overlapping.

Even though it’s transparent, it interferes with the When Triangle is Pressed rule…

4 Likes
#13

Yeah I was figuring that but you have it explained well

1 Like
#14

If this is solved, may I Clive?

1 Like
#15

I think it’s done. You might want to check with @CoderOfMagic first, though.

2 Likes
#16

That’s why I asked lol

1 Like
#17

Ok. Sorry.

2 Likes
#18

Yep all ready to Clive!
I’ll remove the tags ofc!

1 Like
#19

Please don’t close it yet. I’ll explain in a couple minutes

[edit] I’m going to troubleshoot the root cause a bit when I have time. This is still a bug with the Player as the transparent background of the text object shouldn’t prevent the Presses. I recall this being raised before and I thought it was fixed, but perhaps not. I’ll have to do some searching through old posts.

3 Likes
#20

Alright.
Whenever y’all are ready just tag me

1 Like