Bug with values in hopscotch


Use this template to make awesome bug reports:

Your username: Dolphin_Coders

What kind of device are you using?: IPad Air 2

1 sentence description of the problem (I was doing trying to make a star invisible but instead flashed___, and then __________ happened):

Steps to make the problem happen:
1.use values to make invisible
2. Flash non stop

I expected this to happen: to go invisible

But instead this happened: it flashed

Here’s a sweet screenshot:


@MR.GAM3R @Liza @t1_hopscotch @Dylan329 @Anonymous


bruh why did u tag me


I thought you might know + ur on


i dont have hopsoctch havent had it in 2 years no idea how to help sorry


I think I know what is wrong. Say in Star 3’s code, it will set Done to 1, and when it is tapped, it sets Done 2 to 1. The problem is, Done is still set to 1. You will either have to use just Done and have it set to 0 or any number except 1 when tapped, which would mean when Done=0 set invisibility 100%. With that method, you would not need Doen 2. Or, you would have to make Done equal 0 when start is tapped and leave the remaining code. Do I need to explain myself more?


Either way should work


i’ll try that now…


Show us the code please.


I worked it out, but basically I had two values that stuffed it up so to fix it I changed it to one value but set by 1 more


Yep. You had two values determining visibility at once.


Yeah, but this has happened numerous times before with the same value, is it me coding it wrong or a glitch in values?


You were coding wrong. You should add a check over the visibility.

Make it all one rule, do a repeat forever check if else, and do “visibilty100 else 0”


Ok thanks :smiley:


I recategorized this as Debug my Code since it wasn’t a Hopscotch bug.