Bug with Draw a Trail on first frame

The Draw a Trail block doesn’t draw the trail when immediately followed by a Set Position block

Device iPad4,1, iOS Version 10.2, Hopscotch Version 69, Player Version 0041682

@/Liza @/AwesomeOnion @/Rodrigo @/t1_hopscotch

Steps to reproduce bug

  1. Add an object, When Game Starts rule, & Draw a Trail block
  2. Change the default Move Forward to Set Position

This draws a trail as expected

  1. Add another Set Position following the Draw a Trail. The trail no longer draws.

  2. Add any block between the Draw a Trail and the last Set Position. The trail draws again as expected.


  • Only occurs with Draw a Trail using Set Position. Using Move Forward behaves as expected.
  • Only occurs when Draw a Trail is 1st block in When Game Starts rule or 1st block in a conditional rule that evaluates to true in the “1st frame”

I noticed this a while ago.

It really needs to be fixed.

Also, it seems it’s only if it’s the first drawing a trail block in the rule.


I tried fixing this. I would say that there is a confusion between two adjacent set position blocks within the code. Just stick with adding the “wait 0 milliseconds” and it all works fine.

I noticed this a while ago. I thought they fixed it but I guess not.

This is weird, and I hope that THT wil fix this soon.

1 Like