Bug Report: Pixel text weirdness


Username: BlastFusion

Hopscotch version (4 updates earlier from the custom rule one)

Device: iPad iOS 9.2.1 (it’s old I know)

Description: I have actually never used pixel texts on projects post-self updated, and now I tried it and Oof…
What is going wrong - same code and layout but the texts are flipping, recentering, spaces don’t seem to have any effect - it’s bizarre! In the set text everything is fine, but it all goes wrong in the player.

(Don’t focus on the blue) it’s resembling a Pokemon centre, the white and red are acting weird.

and here is the regular code - if this were to be coded on a pre self version everything would work normally.

@awesomeonion, @Liza @Rodrigo

It annoys me how I’m the only pixel texter.


Wat do u mean by pixel texter???


I use pixel text. Just procrastinating on my next game with it.

There is a current bug with set text where any modification happens only at the end and removes all separation between the lines.


don’t use dots.
if you want a line to be in the middle don’t use dots or spaces. If you want to move the text in different directions you can just put those special spaces before or after.


I am not that good at pixel art so I am therefore not good at solving your problem, but it seems like @BB-Box posted a possible solution to your problem.

Also, the game looks awesome so far, I can’t wait to try it when it is done!


Don’t worry, you’re not the only one who know how to do this.

I’ve used pixel text almost only after Self, and it works fine. Could you post just the pixelart here, so we can know what you did wrong?


I followed this tutorial for Hoop Shoot and it worked great:


█████ █████
. ████ .
. █ █ .
. █ █ .
. ████ .
. .
. .
. .

It’s all messed up in this post - click reply then quote it and you’ll see actual text


I tried the “U+3000” spaces that @CreationsOfaNoob posted about.

Same result as BlastFustion’s post above. The forum converted them back to standard spaces.

It would seem the Hopscotch app & player handle the spaces differently than the forum.


Hmm, @BlastFusion I can try to look into it–I don’t think it has to do with self but I could reproduce it on a project in the browser.
Your text objects are crazy though!


I really don’t think I’ll continue this until i know that I can successfully operate on well - produced pixel texts.


Does it work on the Hopscotch app?


That is what the topic is about. It isn’t working in the app.


Weird, because when I made some text art it worked out fine


Could be they were longer than what Hopscotch allows as a line.


Actually I never yet considered this? Does it work in the hopscotch player?


Yes, the “U+3000” spaces work in the Hopscotch player.


This isntcabug, only a certain amount of characters can becused per line, so you are going to have to find a way to shorten the width