Blocks won't follow code HELP!


#1

I'm making a shotgun

this is the code I use. It works perfectly for other blocks, but stopped working only a while ago, is there such a thing as to many blocks?


#2

HALLO!

Welcome to the forum!

We can be friends!


Hmmm I don't know about this

I don't think there is something called that


#3

No I have never heard of that before


#4

Can you put a link for your project?


#5

How? I'm a noob at this


#6

Welcome to the forum! By the way, I moved this to the Bugs category because it's a bug report :wink:


#7

https://c.gethopscotch.com/p/ybwa2gr4k


#8

That link doesn't work. Did you use pictures?


#9

No I haven't but how do you put a link to ur project


#10

Yay it works now, at least works for me


#11

I was talking about the link, just to make things clear.


#12

It still doesn't work for me...


#13

cant you just open it n hopscotch? And what happens when you press the link?


#14

My project is called Shotgun Mark1 unfinished


#15

I can't open it in Hopscotch because I'm using a computer. By the way, it's still not working... Try looking at this topic:


#16

Mine don't have any bad words and as far as I can see it's appropriate.


#17

Try putting all that code in a repeat forever block, or change that block into a "Check Once If" block instead, because it doesn't seem like you have anything in the "Else" place.
What's weird is that it works for all your other objects.
Oh, and welcome to the forum!


#18

When has the change x bit maybe you need to have a wait block in between (for a short amount of time). I assume it is supposed to move from side to side?

Btw welcome to the forum!:slight_smile:


#19

Can you give me a link so I can help


#20

I fixed it :D
I just added a before it sets the value "ammo" to 0. The problem was that the handle didn't have time to "see" the ammo value as 1. I hope you understand how I mean!