Blocks on screen while playing?!?!

Use this template to make awesome bug reports:

Your username:
ExplodingDucks🐥
What kind of device are you using?:
iPad7,5 iOS Version: 1.5.2
1 sentence description of the problem (I was doing _________, and then __________ happened):
I was minding my own business making coded ice cream and I click play while editing and the code stuff was still there because my iPad was being weird.
Steps that the Hopscotch team can take to reproduce my problem every time:

  1. Open a project and make code
  2. Click “Play” while in the edit code thing
    ….

I expected this to happen:
No code blocks
But instead this happened:
Code blocks!
Here’s a sweet screenshot:

17 Likes

This bug or a similar bug has been reported before. I think this is a small glitch. Exiting the editor or project should fix it.

If this has been reported many times, maybe it should be brought to THT’s attention more so it doesn’t happen again. Just a general thought to all :))

12 Likes

Yeah this is a pretty common bug. Restarting the editor fixes it.

Pretty sure THT fixed this, must’ve popped up again after a recent update.

Next time, for a common issue, might just wanna bump an existing topic instead of making a new one tho.

6 Likes

Yeah, I thought this was the bug where the blocks appear once you exit the project. Pretty similar.

6 Likes

Yes this happens to me too

4 Likes

I think you iOS version is wrong. Go to the settings app > general > about to see your iOS version. I think the version you gave is your ‘player‘ version

Unless you were saying that it is an iOS device

4 Likes

Extremely annoying
Happens 10 times a day
I think it was kinda fixed on some projects if you went back to the code.

3 Likes

oh, this happens ALL the time. go out of the project, play in “explore” for a while, then get back to coding. if this doesn’t work, then play on another app for a few minutes. =)

4 Likes

Yeah, happens to me sometimes.
Just return to the editor and close the keyboard

2 Likes

yeah as it doesn’t need a whole new topic for the same issue


I haven’t had this bug recently but I do get it sometimes

2 Likes

Same, tho I haven’t been on hs all that much recently, just checking the forum for 10 mins every morning, and evenening

1 Like

This is a common bug, but there is already another topic on this.

2 Likes
3 Likes

That’s when you exit the editor/project. Here, it pops up when you exit the object.

Similar though

3 Likes

they’re basically the same thing I think/probably have the same cause

2 Likes