Block menu stays up after exiting editor/project

I know this bug, it happened to me a lot when I tried to fix my clock on HS.

To fix: Click Edit and then click play, but not immediately, maybe an interval of a few seconds.

Why does it happen?: Sometimes, when HS expects for you to put a block, it puts the highlights, right? But when it was coming up with the animation, you clicked Edit immediately, before it could respond, and while it was in animation, so it was put in a file 404. It couldn’t put the back animation, so if trigger the animation again, but let it do the original thing it was supposed to do, it should be fixed.

I’m pretty sure I’m late, but idk… h0p3 it h3lps…

-Albus

2 Likes

This continues happening to me, this deserves a revive.

2 Likes

Yeah it happened to me today

1 Like

I wonder if we could instead be able to close it by shaking the device.

2 Likes

revive

I can’t consistently reproduce this but it happens on a regular basis

1 Like

Far more often now with the new update

This happens to me as well… every single time when adding code to an object on a different scene (perhaps it happened after adding two rules to the object). Can be resolved temporarily by quitting the app. Hope THT fixes this issue.

1 Like

Possibly. Haven’t coded in a while so idrk?

1 Like

this wasn’t quite resolved as it happened again yesterday but its really infrequent for me

Use this template to make awesome bug reports:

Your username: The Wild Fox

What kind of device are you using?: IPhone 12 Pro Max

1 sentence description of the problem (I was doing _________, and then __________ happened):

I was playing around with the beta editor and then when I tried to exit my project, the editing option still popped up.

Steps that the Hopscotch team can take to reproduce my problem every time:

  1. Use the beta editor
  2. Click add code
  3. Exit out of your project.
  4. See the bug
    ….

I expected this to happen:
The block editor to go away when I exit out of my project.

But instead this happened:

It did not go away.

Here’s a sweet screenshot:

5 Likes

I have this when i got the beta editor

1 Like

Im curious, what happens when you press the code blocks?
Really, ive seen this before

1 Like

Hmm good question. I’ve never tried that. Haven’t coded recently so I havem’t had the bug since I made this report actually.

1 Like

I ran into this last week again

I still see this bug too!

2 Likes

Yeah, it is still around. It has occurred to me recently as well. However, I feel like this error generates less frequency than it has in the past, but it is not entirely gone.

3 Likes

Yeah me to lol

1 Like

Weird bug btw

Happens to me

2 Likes

bump

I’ve run into this 3 times in the past 2 day

3 Likes

The actually just happened to me Weird thingy idk what to call it

1 Like